Remote desktop with error code 0x4 while on VPN

Kansi 101 Reputation points
2020-11-24T16:12:46.703+00:00

Hi, I'm using Win10 pro and on FortiClient and tried to remote a desktop that on VPN. Two months ago, I'm able to connect in the same setting, but it isn't for now.

Somehow I'm able to connect on my iphone with the RD Client under the same network setting.

below is the full error that when I tried to connect to that pc.

Disconnect code: UnknownError, legacy code: 0x4, legacy extended code: 0x0, activityId: {adad1d6a-6250-40c5-923f-4fb59cb80000}

Any suggestion?Thank you.

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,400 questions
{count} vote

5 additional answers

Sort by: Most helpful
  1. Eleven Yu (Shanghai Wicresoft Co,.Ltd.) 10,726 Reputation points Microsoft Vendor
    2020-11-25T05:51:02.683+00:00

    Hi,

    Are you using mstsc to remote connect to the PC?
    Could you please share a screenshot of the error message you got when you try to connect?

    Since you can use iphone to remote connect to the PC with RD Client, please try below action to see if the issue could be resolved or not.

    After connecting to the remote PC using iphone, set this key to a high value, like 10,000

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server

    MaxOutstandingConnections (REG_DWORD)

    Thanks,

    Eleven

    If the Answer is helpful, please click "Accept Answer" and upvote it. Thanks.

    1 person found this answer helpful.
    0 comments No comments

  2. SenhorPC 1 Reputation point
    2020-11-28T14:48:28.967+00:00

    Same issue in Android :(

    0 comments No comments

  3. LUIS SANTAMARIA 1 Reputation point
    2020-11-29T07:07:53.95+00:00

    Hello!! I have the same problem. I can connect with the iPad but not with MAC. I connect with VPN to SERVER with WINDOWS SERVER 8 R2.

    Please Help me

    0 comments No comments

  4. jgeisler 1 Reputation point
    2021-01-13T15:36:45.41+00:00

    I have the same problem, is there a solution?

    Thanks

    0 comments No comments