Internal mail problem

DzoITAdmin 1 Reputation point
2020-11-25T11:59:16.527+00:00

Environment:Windows Server 2016 - Exchange Server 2016 CU15

On one shared mailbox, there is a issue, that when email is sent to it, users don't get that email.
Tested with Test-Mailflow Result, email do arrive at it's destination, but disappear after a second.

Restart of the exchange services solve issue, but I have also confirmed that if only Exchange Information Store service is restarted, it also works fine afterwards.
But only for some time.

I have checked with Get-InboxRule -Mailbox command on Exchange Management Shell, and mailbox has one rule which is correct, that is to delete email which come from specific address.

Mailbox is in correct database, as this is only database I have.

In Message Tracking Log I see that email is successfully delivered. There is no pointing to specific folder or something.
There is one redirect, but for this it is set up to forward mail to specific address, with option to deliver to both forwarding address and mailbox, enabled.

Any suggestions ?

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,339 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Andy David - MVP 141.2K Reputation points MVP
    2020-11-25T12:16:17.16+00:00

    Disappear to where? Is the message in the dumpster of the shared mailbox?
    Sure there isnt a POP or IMAP client accessing this shared mailbox? Or another non Outlook client at all? (Mobile etc...)

    Enable mailbox auditing and see whats happening to the messages:

    https://learn.microsoft.com/en-us/exchange/policy-and-compliance/mailbox-audit-logging/enable-or-disable?view=exchserver-2019


  2. Yuki Sun-MSFT 40,781 Reputation points
    2020-11-26T02:24:17.883+00:00

    Hi @DzoITAdmin ,

    Does this issue only affect the particular shared mailbox and occur to all messages sent to it?

    Restart of the exchange services solve issue,

    By this, do you mean the missing messages will appear after the services are restarted? Or you mean new emails sent to the shared mailbox can arrive as expected?

    Don't know actual location where message went, that's the issue. Not in dumpster.

    Have you checked in OWA to see if the mails are there?
    Aside from the dumpster, it's suggested to try search within the entire mailbox using the subject or other keywords of the problematic message and check the result.


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.