eDscovery Export Download not working in Edge

Jeremy King 126 Reputation points
2020-11-26T17:41:40.133+00:00

I am doing an eDiscovery in Exchange Online, and have done an export of the search results which I am now trying to download.

I did this first in Chrome, which downloaded Microsoft.Office.Client.Discovery.UnifiedExportTool.application, but when it ran it came up with an error "Application cannot be started. Contact the application vendor". At the top of the screen I saw it said the export should be done in Edge. So...

...Moving onto Edge, when I click the "Download Results" button I get a pop-up window asking me to confirm that I want to open Microsoft.Office.Client.Discovery.UnifiedExportTool.application from complianceclientsdf.blob.core.windows.net.

43101-edge.png

I click "Open" and the pop-up window reappears. Every time I click Open it just happens again (each time a new "Untitled" tab opens with a URL pointing to https://complianceclientsdf.blob.core.windows.net/v16/Microsoft.Office.Client.Discovery.UnifiedExportTool.application?source=........ but nothing gets downloaded or run - just the box comes up again).
43102-edge2.png

I've tried on IE too. First attempt, when I clicked on "Open" it opened a new tab in Edge!! Changed my default browser to edge, and this time when click "open" it goes into a loop very quickly opening and closing the "Downloads" window repeatedly until close IE. Nothing in Eventvwr to suggest what was going on there

I've tried it on two different PCs (work and home) but get the same result each time. Anyone got any ideas?

Thanks

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
2,161 questions
Microsoft Exchange Online Management
Microsoft Exchange Online Management
Microsoft Exchange Online: A Microsoft email and calendaring hosted service.Management: The act or process of organizing, handling, directing or controlling something.
4,228 questions
0 comments No comments
{count} votes

Accepted answer
  1. Vasil Michev 96,436 Reputation points MVP
    2020-11-26T19:58:35.087+00:00

    The download tool uses the click-once technology, which is only supported by IE. All other browsers need add-ins or additional configuration to properly support it, as detailed in the documentation: https://learn.microsoft.com/en-us/microsoft-365/compliance/configure-edge-to-export-search-results?view=o365-worldwide


2 additional answers

Sort by: Most helpful
  1. Jeremy King 126 Reputation points
    2020-11-26T20:10:06.673+00:00

    Thanks Michev

    Should have said, I had come across that in my earlier searching for a solution and had enabled the ClickOnce Support (and confirmed no policy set). This was partly why I also tried it in IE but sadly that didn't work either.

    1 person found this answer helpful.

  2. Jeremy King 126 Reputation points
    2020-11-26T20:21:21.937+00:00

    Hi Michev

    Just to add to my earlier answer - if I try it with ClickOnce Support disabled, it downloads the Microsoft.Office.Client.Discovery.UnifiedExportTool.application file, in the same way that Chrome does, and it fails to run when downloaded that way (as I found with Chrome too)

    At least this proves that setting it to Enabled causes different behaviour, but something's stopping it working.

    1 person found this answer helpful.
    0 comments No comments