Server returned '400 4.4.7 message delayed' when send to office 365

Phuong Nguyen 166 Reputation points
2020-11-27T10:00:12.84+00:00

Dear MS,

Currently I am having an error that the user's email returns an error.

My system email Server exchange 2016 send to Office 365

Almost sending emails to office 365 returns an error.

Server returned '400 4.4.7 message delayed'

43150-2020-11-27-15-51-00.jpg
I check my log mail queu email
43198-2020-11-27-16-36-10.jpg

Please help me

Many thanks

Microsoft Exchange Online Management
Microsoft Exchange Online Management
Microsoft Exchange Online: A Microsoft email and calendaring hosted service.Management: The act or process of organizing, handling, directing or controlling something.
4,149 questions
Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,323 questions
{count} votes

Accepted answer
  1. Andy David - MVP 140.8K Reputation points MVP
    2020-11-28T00:20:19.53+00:00

    Ok, when did you start seeing this? Did you just start sending to Exchange Online from this IP? Exchange Online will greylist and back off connections it hasnt seen before in some cases. Especially if they are "spammy" in nature. Usually, after that iniitial back off period, EOP will allow these and they will go through

    3 people found this answer helpful.
    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. Phuong Nguyen 166 Reputation points
    2020-11-27T20:32:52.337+00:00

    Hi AndyDavid
    I run on-premise standard alone.
    My configuration Exchange full and correctly
    MX: mail.vfc.com.vn->
    43276-image.png
    PTR IP resverse: 43328-image.png
    SPF: 43329-image.png

    451 4.7.500 Server busy. Please try again later from [183.91.25.131]. (S77719) [HK2APC01FT023.eop-APC01.prod.protection.outlook.com]

    I have check log from Exchange error
    43298-image.png

    0 comments No comments

  2. Phuong Nguyen 166 Reputation points
    2020-11-28T12:03:10.187+00:00

    Thanks @Andy David - MVP
    My system is normal before and ensures full security configuration DNS (MX, SPF, PRT) of Office 365 when sending to customers using MS services O365.
    I got the above error from 2:00 p.m. December 27, 2020 from around 12 o'clock to finish processing. Previously, there was no listing blocklist but now it is :( I also don't know the reason.
    After I restarted the Exchange email server the email was sent successfully to My Email Customer use O365.
    I don't know because I restarted the server so I dropped the email queue to send email to MS EOP and the EOP secure email spam system automatically removed my IP mail
    Or because MS removed the IP from the blocklist.
    I do not know how long will the EOP system of MS block IP take to remove eg 8 hours and 12 hours :)
    Anyway, thanks very much for Support. My exchange system has now successfully sent emails to customers using Office 365

    0 comments No comments