Office Message Encryption - Disable Encrypt Button in Outlook

Peters, Marvin 21 Reputation points

Hi eyeryone,

maybe someone know this. FYI, we are using M365 with EXO.

Can I disable the encrypt button in my installed Outlook application as it is shown in the following screenshot?


I know that it is possible in OWA, but I can´t find the option for the local Outlook. I think, maybe it is possible with a registry key?
In my situation, it is not enough to disable the "Encrypt only" or "Do not forward" Button, because than there are only greyed out.

The goal is to disable this button for every user (via GPO for example), so the user must use a AIP Label to protect emails.

Thanks a lot and kind regards
Marvin Peters

Outlook Management
Outlook Management
Outlook: A family of Microsoft email and calendar products.Management: The act or process of organizing, handling, directing or controlling something.
4,947 questions
0 comments No comments
{count} votes

7 answers

Sort by: Most helpful
  1. Vasil Michev 97,076 Reputation points MVP

    You can disable any control as long as you know the corresponding ID, read for example here:

    1 person found this answer helpful.
    0 comments No comments

  2. David Garza 1 Reputation point

    @JeffYang-MSFT This does work however it disables all of DRM therefore others issues may arise. We have just done this in our Org and now encrypted messages from other organizations for the use of webmail. Which in our org posses other difficulties. Do you know if there is a way to hide that button?

    @Vasil Michev DO you happen to know the command ID for this button, 718? I have tried but cannot get it to work at all. Other buttons I have hidden, are indeed hidden, however no affect to the Encrypt button.

    0 comments No comments

  3. mbfischer 0 Reputation points

    Do you solve this issue. I want to hide that button, too. ID 718 doesn't work.

    0 comments No comments

  4. David Garza 1 Reputation point

    @mbfischer We used GPO preference to disable DRM, which I believe removed the button. but we only wanted to disable Encrypt Only so we changed to disableEO.

    Hope this helps.

    User's image

    0 comments No comments

  5. Lareau, Alexandre 0 Reputation points

    I had a similar issue and opened up a ticket with premier support.

    This is what I was given and it worked.

    Value type: REG_SZ ( string value )
    Value name: TCID1
    Value = 32644