Because of a protocol error (code: 0x112f), the remote session will be disconnected. Please try connecting to the remote computer again. Error code: 0x4

David 0 Reputation points
2024-06-30T06:20:36.82+00:00

I had no problem logging into the virtual machine until Thursday now I get

Because of a protocol error (code: 0x112f), the remote session will be disconnected.

Please try connecting to the remote computer again.

Error code: 0x4

Extended error code: 0x112f

User's image

I've tried the following things:

  • Restarting my local machine and the virtual machine
  • Trying on a different computer
  • Only using one screen
  • Changing gpedit.msc WDDM disable on VM and local
  • Changing environment settings, display settings etc on MS RDC
  • Changing NIC
  • Redeploying VM

I am completely out of ideas now. Does anyone have any idea how to fix this problem?

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,566 questions
{count} votes

2 answers

Sort by: Most helpful
  1. hossein jalilian 5,475 Reputation points
    2024-06-30T23:16:51.9966667+00:00

    Thanks for posting your question in the Microsoft Q&A forum.

    The error you're encountering (code 0x112f) is often related to Remote Desktop Protocol issues.

    • Ensure that the NSG associated with your VM allows inbound RDP traffic (port 3389).
    • Ensure you're using the latest version of the Remote Desktop client on your local machine.
    • Use the Azure portal to verify that RDP is enabled on the VM and that the correct port is being used.
    • Try accessing the VM through Azure Serial Console to check for any system-level issues.
    • Use Azure Serial Console or run diagnostic tools to check for any system errors or warnings.
    • Check both the Azure and VM-level firewall settings to ensure RDP traffic is allowed.
    • Use Azure portal to reset the RDP configuration of the VM.

    Please don't forget to close up the thread here by upvoting and accept it as an answer if it is helpful


  2. kobulloc-MSFT 26,131 Reputation points Microsoft Employee
    2024-07-05T22:46:27.8+00:00

    Hello, @David !

    Why am I running into code: 0x112f when using remote desktop?

    Several people have reported this error as being caused by multiple monitors:

    https://learn.microsoft.com/en-us/answers/questions/292214/protocol-error-code-0x112f-on-local-machine-solved

    An update to this: I have found that if you connect using only one monitor first (uncheck "Use all my monitors for the remote session" in the "Display" tab before connecting), and then connect using all monitors while still being connected with one monitor, the multi-monitor connection will "take over" and successfully connect without the 0x112f error. Hope this helps!

    This seems to be related to a memory limitation, so reducing display settings, clearing memory consuming tasks, or increasing the VM size/resources may work as well.


    I hope this has been helpful! Your feedback is important so please take a moment to accept answers.

    If you still have questions, please let us know what is needed in the comments so the question can be answered. Thank you for helping to improve Microsoft Q&A!

    User's image

    0 comments No comments