Azure DevOps Pipeline Failure Due to 'Short-Circuit and Authentication Error'

VT DevOps 10 Reputation points
2024-07-01T09:27:53.9966667+00:00

We encountered a critical issue with our Azure DevOps pipelines that disrupted our deployment process.

Issue Description:

Circuit Breaker 'AzureBlobProviderRead.FetchAttributes' short-circuited. In the last 10000 milliseconds, there were: 0 failures, 0 timeouts, 130 short-circuits, 0 concurrency rejections, and 0 limit rejections. Last exception: Microsoft.Azure.Storage.StorageException Server failed to authenticate the request. Make sure the value of the Authorization header is formed correctly, including the signature.

Additionally, the same error unexpectedly appeared on the production pipeline triggered by a push from UAT. This behaviour is unusual since the production pipeline should only be triggered by pushes to the master branch, which has worked correctly in the past.

Request for Assistance:

  1. Clarification and Insights: We need more information about the AzureBlobProviderRead.FetchAttributes short-circuit error and the authentication issue.
  2. Resolution Steps: Guidance on troubleshooting and resolving this issue to prevent future occurrences.
  3. Pipeline Triggering: Insights into why the production pipeline was triggered by a UAT push and how to ensure it only triggers from the master branch pushes as intended.

Any advice or solutions to these problems would be greatly appreciated. Thank you in advance for your support!

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
37,631 questions
{count} vote

1 answer

Sort by: Most helpful
  1. Jayesh Patel 10 Reputation points
    2024-07-09T08:34:12.62+00:00

    Good morning,

    we have the same issue as reported this morning:

    Circuit Breaker "AzureBlobProviderRead.FetchAttributes." short-circuited. In the last 10000 milliseconds, there were: 3 failure, 0 timeout, 138 short circuited, 0 concurrency rejected, and 0 limit rejected. Last exception: Microsoft.Azure.Storage.StorageException Server failed to authenticate the request. Make sure the value of Authorization header is formed correctly including the signature.

    109295

    this seem to happen in all our pipelines yesterday some ran without us trigering so not sure why they ran

    all failed within a second with the same error

    0 comments No comments