How should I connect DataFactory to a SFTP Server?

G S, HarisKumar 0 Reputation points
2024-07-01T15:16:18.8866667+00:00

Hi,

I'm trying to connect My DataFactory to SFTP Server. I have all the details necessary to connect. But I'm currently facing:

Invalid Sftp credential provided for 'SshPublicKey' authentication type.
openssh key type: ssh-rsa is not supported

What should be done in this case? Which Algorithm should we use?

Note: I tried using ECDSA and EC25519.

Can anyone help me out with this?

Thanks

Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
10,132 questions
{count} votes

1 answer

Sort by: Most helpful
  1. phemanth 8,645 Reputation points Microsoft Vendor
    2024-07-01T17:51:22.48+00:00

    @G S, HarisKumar

    Thanks for reaching out to Microsoft Q&A.

    The error message indicates that the provided SFTP credential is invalid.

    Check the Encoding of Your Private Key: The error message you’re seeing can occur if the private key content is fetched from the Azure key vault or SDK, but it’s not encoded correctly. The private key content should be base64 encoded SSH private key content. You can encode the entire original private key file with base64 encoding and store the encoded string in your key vault. The original private key file is the one that can work on the SFTP linked service if you select Upload from the file.

    Check the Authentication Type: The specified authentication type might not be allowed or sufficient to complete the authentication in your SFTP server. If your server requires a password, use “Basic”. If your server requires a private key, use "SSH public key authentication".

    Try a Different Key Algorithm: It seems you’ve tried using ECDSA and EC25519. If these are not working, you might want to try using a different key algorithm. Please check with your SFTP server documentation or support to find out which key algorithms are supported.

    Remember to always store sensitive data such as keys and passwords securely, for example in Azure Key Vault.

    if you still face the issue, please do let us know.

    0 comments No comments