Multiple public ips are not getting added in Azure FW

Ananya Sarkar 311 Reputation points
2020-11-30T09:14:54.9+00:00

Hi,

I am trying to add two public ips in Azure FW through power shell command as mentioned in MS documentation. However i could see that the two ips got created in the resource group and when i create the FW with these two ips, it got created successfully, but only one public ip is displaying in the FW overview page and not both the ips. Is it the expected behavior?
How can i test if both the ips are working for this FW, in this case?

Azure Firewall
Azure Firewall
An Azure network security service that is used to protect Azure Virtual Network resources.
563 questions
0 comments No comments
{count} votes

Accepted answer
  1. suvasara-MSFT 9,996 Reputation points
    2020-11-30T12:56:38.68+00:00

    @Ananya Sarkar , I have tested this in my lab where I observed that Public IP added to an Azure FW using PowerShell is missing on the portal view but is been tagged to the firewall in the backend. See this screenshot,

    Explanation: azFwPublicIp1 is the IP configuration I have added to firewall using PowerShell. But as I can't see this on the firewall, I decided to tag from the portal. Then I faced this error saying it is already tagged in the backend.

    PIP added with PowerShell Commands:

    43646-image.png

    Azure Portal: It reflects in the IP configuration list and working as expected if I create it from the portal,

    (My Public IP name = second-ip) --> for your reference

    43615-image.png

    So, it looks like a kind of bug. We will report this to the respective product team for a quicker resolution. Meanwhile, please try using other methods of deployment like Portal or CLI.

    ----------

    Please do not forget to "Accept the answer" wherever the information provided helps you to help others in the community.


0 additional answers

Sort by: Most helpful