Index created from Missing Index reappears

Ravi 1 Reputation point
2020-11-30T15:02:38.797+00:00

In SQL 2016, created Indexes from Missing Indexes.

To defragment Index Rebuild with Online and Executed missing index on Next day. Same index reappears as missing Index Report. It gets disappeared from missing index report after I rebuild only the specific index manually. This happens for multiple Indexes in the database.

CREATE INDEX missing_index_65398_65397 ON [SCHEMA_Name].[TABLE_NAME] ([COLUMN_NAME], [COLUMN_NAME]) INCLUDE ([COLUMN])

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
12,665 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Erland Sommarskog 100.9K Reputation points MVP
    2020-11-30T23:11:41.713+00:00

    Your post is not very clear. However, I like to point out that you should not create all missing indexes that are reported. This will result in that you have too many indexes. See the missing-indexes report as a recommendation or rather a tip. You should make a judicious choice of whether you should actually implement that index.

    1 person found this answer helpful.
    0 comments No comments

  2. CathyJi-MSFT 21,081 Reputation points Microsoft Vendor
    2020-12-01T08:20:37.597+00:00

    Hi @Ravi ,

    From your description, it seems you rebuilt missing index according to missing index report. What is your issue? You meet error during rebuilt index? If I misunderstood, please let me know.

    Suggest you read the blog Don't just blindly create those "missing" indexes!

    Best regards,
    Cathy

    1 person found this answer helpful.