The RemoteApp that will not die!

Jeff 156 Reputation points
2020-12-01T09:33:09.093+00:00

I published an app to our 2012 R2 Remote Desktop application collection.

It was called "CRM" and was actually an instance of Chrome with a URL given as a required parameter to our Dynamics CRM.

At first it had an icon of the Chrome application, but I worked out that I could create a ,ico file called "CRM" and get it to use that instead, though it didn't do it straight away (I had to reboot the Broker/Web Access server, then publish another app from Powershell before the dang thing would use the new icon!

Now it turns out that the project team want it to be called "Dynamics CRM".

So, I changed the Display Name AND the alias AND the .ico file.

But it's still showing as "CRM".

I've rebooted the broker/Web Access server, and tried publishing another app ("CRM Test", using the URL to the test instance of Dynamics) using PowerShell, but to no avail. Even the new 'test' app doesn't show.

Any ideas what's going on?

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,227 questions
0 comments No comments
{count} votes

Accepted answer
  1. Jeff 156 Reputation points
    2020-12-12T13:11:29.43+00:00

    Anyway, it's all working now.

    Something we discovered was preventing the publication of apps was if I created a custom .ico AND had it in place with the correct name (matching the alias rather than the DisplayName).

    It seems the system tries to create its own .ico file with the same name but then fails because an icon file with that name exists but it doesn't seem to have the rights to overwrite it.

    So, if I publish the application with no pre-existing .ico file the publish process completes successfully. I can then copy over the custom .ico file afterwards no problem.

    I don't know why I got the error about the Collection Name not found, but after a reboot that error hasn't re-occurred.

    Thanks for your help.

    0 comments No comments

6 additional answers

Sort by: Most helpful
  1. Eleven Yu (Shanghai Wicresoft Co,.Ltd.) 10,671 Reputation points Microsoft Vendor
    2020-12-02T03:04:29.953+00:00

    Hi,

    Have you tried to unpublish the app (CRM) and app (CRM Test) and then republich the app (Dynamic CRM)?

    Thanks,

    Eleven

    If the Answer is helpful, please click "Accept Answer" and upvote it. Thanks.

    1 person found this answer helpful.

  2. Eleven Yu (Shanghai Wicresoft Co,.Ltd.) 10,671 Reputation points Microsoft Vendor
    2020-12-04T07:02:26.787+00:00

    Hi,

    Can you please have a try to use GUI to unpublish the app instead of the command remove-rdremoteapp?
    44950-image.png

    Please check the event logs related to remote desktop/remoteapp on the RDSH and RDCB servers to see if there is any detailed error message for "could not create a published appliction..."

    After researching, I find there are some users successfully resolve the error you shared by re-applying the certificates. You can also have a try.

    45049-image.png

    Thanks,
    Eleven

    ----------

    If the Answer is helpful, please click "Accept Answer" and upvote it. Thanks.

    0 comments No comments

  3. Jeff 156 Reputation points
    2020-12-04T15:51:40.24+00:00

    Hi, Eleven

    Good idea! Without going as far as re-applying the certificate that has improved matters . I now have two icons with the correct names.

    Not the correct icons though, they still show as the 'chrome' icon rather than the custom .ico I've added to the folder.

    0 comments No comments

  4. Jeff 156 Reputation points
    2020-12-04T17:38:09.697+00:00

    I gather that the Web Access server/service needs to be restarted in order for it to use the .ico file(s). I'll do this later on when staff have logged off.

    For the sake of being tidy, I unpublished the "Dynamics CRM" app again, then tried re-adding it using PowerShell in order to give it an alias other than the default of "chrome (x)".

    This produces an error that it can't find the named session collection (even though I confirmed that collection name immediately beforehand:

        PS C:\> Get-RDSessionCollection
    
        CollectionName                 Size ResourceType
        --------------                 ---- ------------
        Remote Applications            4    RemoteApp programs
    
        PS C:\> New-RDRemoteApp -CollectionName "Remote Applications" -alias "Dynamics CRM" -DisplayName "Dynamics CRM" -FilePath "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" -VirtualDesktopName "%SYSTEMDRIVE%\Program Files (x86)\Google\Chrome\Application\chrome.exe" -CommandLineSetting "Require" -RequiredCommandLine "https://BLAHBLAH.BLAH.dynamics.com" -ShowInWebAccess $true
    
        New-RDRemoteApp : The virtual desktop collection "Remote Applications" could not be found.
        At line:1 char:1
        + New-RDRemoteApp -CollectionName "Remote Applications" -alias "Dynamics CRM" -Dis ...
        + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
            + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
            + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,New-RDRemoteApp