Azure App Service Unable to Target 5.0.100 HTTP Error 500.31 - ANCM Failed to Find Native Dependencies

Kai Langlie 1 Reputation point
2020-12-01T20:20:24.353+00:00

"The specified version of Microsoft.NetCore.App or Microsoft.AspNetCore.App was not found."

Everything I've read led me to believe that .NET 5 is ready to be used for an app service. So I made the necessary changes and merged my code. The build (pipeline) went find. The release made it to the App Service. But for some reason the machine with the App service does not have .NET 5 installed. My question is, am I wrong in assuming that Azure is raeady to host .NET 5 applications. If it is possible, then how do I do this?

.NET Runtime
.NET Runtime
.NET: Microsoft Technologies based on the .NET software framework.Runtime: An environment required to run apps that aren't compiled to machine language.
1,136 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Jaliya Udagedara 2,736 Reputation points MVP
    2020-12-02T07:11:40.897+00:00

    Azure App Services supports .NET 5: Read More: .NET 5 now available in App Service

    Did you change the target framework of your app service to be .NET 5?

    44267-image.png

    If you are creating a new app service, you can see .NET 5 under Runtime stacks.

    44331-image.png

    Please let us know if you are still facing issues trying to target to .NET 5.

    0 comments No comments

  2. Michael Hansen 1 Reputation point
    2021-01-13T06:50:58.567+00:00

    After changing Platform from 32 to 64 bit, everything worked fine.


  3. D M 96 Reputation points
    2021-05-03T19:29:48.187+00:00

    Also having this problem, but chaging to .Net 5.0 did not solve the problem.

    I cannot change to 64bit because the drop down is greyed out.

    When I run set pro in the console it appears to be on 64bit, even though it says 32bit in the greyed out dropdown.

    This is very frustrating.