RDP does not connect

Rafael Mello 96 Reputation points
2020-12-03T12:07:16.933+00:00

Hi.

Guys, I have a problem with 2 servers, one on each client.

Out of nowhere the remote desktop server has stopped, it doesn't connect for anything.

I have the ports released on the firewall, the service active.

I tried to change the port, I changed the registry according to tutorials on the net and nothing.

I put the service to listen on a door of another service that works (of course I stopped that other service)

and does not connect.

I did sfc / scannow, DSIM, windows update and etc.

One server is Windows Server 2012 and the other is Windows Server 2012 R2.

Any tips?

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,466 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,346 questions
0 comments No comments
{count} votes

Accepted answer
  1. Rafael Mello 96 Reputation points
    2020-12-03T19:23:08.807+00:00

    Hello, I was able to resolve it by backing up the HKEY_LOCAL_MACHINE \ System \ CurrentControlSet \ Control \ Terminal Server \ WinStations \ RDP-Tcp from a server with the same version of the operating system and I deleted the problem servers.

    I restored that backup and it worked right away.

    Thanks for listening.

    0 comments No comments

3 additional answers

Sort by: Most helpful
  1. Dave Patrick 426.4K Reputation points MVP
    2020-12-03T13:13:51.417+00:00

    Might try from PowerShell on both source and target.

    Test-NetConnection -ComputerName "192.168.49.142" -CommonTCPPort "RDP" -InformationLevel "Detailed"

    --please don't forget to Accept as answer if the reply is helpful--

    0 comments No comments

  2. Rafael Mello 96 Reputation points
    2020-12-03T13:59:05.903+00:00

    @Dave Patrick Failed on both

    44788-capturar.png

    0 comments No comments

  3. Dave Patrick 426.4K Reputation points MVP
    2020-12-03T14:08:29.707+00:00

    Looks like the Remote Desktop Services (TermService) service is not running on 192.168.0.11 or is not listening on port 3389

    If you changed the listening port then you could test using (example)

    Test-NetConnection -ComputerName "192.168.49.65" -Port 3399 -InformationLevel "Detailed"

    --please don't forget to Accept as answer if the reply is helpful--

    0 comments No comments