exchange 2013 cannot connect to EMS

alessandro belli 131 Reputation points

I have this problem since a lot of time and still not able to solve
When I try to connect to exchange 2013 trow the consolle I get this error:

VERBOSE: Connecting to
New-PSSession : [] Connecting to remote server failed with the
following error message : WinRM cannot complete the operation. Verify that the specified computer name is valid, that
the computer is accessible over the network, and that a firewall exception for the WinRM service is enabled and allows
access from this computer. By default, the WinRM firewall exception for public profiles limits access to remote
computers within the same local subnet. For more information, see the about_Remote_Troubleshooting Help topic.
At line:1 char:1

  • New-PSSession -ConnectionURI "$connectionUri" -ConfigurationName Microsoft.Excha ...
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  • CategoryInfo : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [New-PSSession], PSRemotin
  • FullyQualifiedErrorId : WinRMOperationTimeout,PSSessionOpenFailed
    VERBOSE: Connecting to

I follow some article, like

check the certificate on backend (changed between the public certificate and the exchange builtin one)
check then Winrm listener

Winrm enumerate winrm/config/listener
Address = *
Transport = HTTP
Port = 5985
Enabled = true
URLPrefix = wsman
ListeningOn =,, ::1, fe80::5efe:, fe80::29

the only solution is to restart the server than it works for some days than stop again

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,322 questions
0 comments No comments
{count} votes

Accepted answer
  1. Lucas Liu-MSFT 6,161 Reputation points

    Hi @alessandro belli ,
    According to the information, you means that restart the Exchange server can temporarily solve this issue, then it will suddenly appeared.
    I noted that you change the certificate in IIS, please make sure that the port 444 on backend in IIS binding the Microsoft Exchange certificate. When you make any changes in IIS, please restart IIS to ensure that the changes take effect.

    1. Please try to run the following command to whether you configure the proxy settings, it should show direct access (No proxy server):
      netsh winhttp show proxy
    2. Please try to run the following command to check whether the WinRM service is started and whether the configuration is successful:
      winrm quickconfig
    3. According to research the similar cases, if the function is suddenly interrupted, it is possible that the service has stopped suddenly, so please check whether all services are running normally after the problem is reproduced. And when the memory usage on the server is maxed, it also could cause this issue, so please check the CPU and memory usage when issue occurred.
    4. Please make sure that there are exceptions for port 5985 for HTTP, and/or 5986 for HTTPS. And if there any anti-virus software installed on your Exchange server, please try to temporarily shut down.
      There is a related blog you can refer to: WinRM cannot complete the operation
      Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.
      In addition , please check whether there are any related error logs in the event viewer. If there are, please share with us, but you need to pay attention to covering your personal information.


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. alessandro belli 131 Reputation points

    still working.
    Thank you

    0 comments No comments