Webbrowser not shown in Toolbox

Roland Löffler 21 Reputation points

I have activated the Webbrowser in Extras/Toolboxelements but its not shown in the Toolboxlist.

What do i wrong?

Visual Studio Testing
Visual Studio Testing
Visual Studio: A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.Testing: The act or process of applying tests as a means of analysis or diagnosis.
325 questions
{count} votes

4 answers

Sort by: Most helpful
  1. Vivzi 6 Reputation points

    I'm really sorry to say, but you must recreate your winforms project with the version which has the .NET Framework.

    1 person found this answer helpful.
    0 comments No comments

  2. Henri 6 Reputation points

    I had the same problem as Roland. I could not find WebBrowser in the toolbox, and none of the tips above worked for me.

    What I did instead: I added a Button control where I wanted my WebBrowser control. Then I manually changed the code in the Designer.cs file to replace the button with a WebBrowser instance. Once the control is on the form, I can reposition it normally in the GUI editor.

    A bit clunky, but maybe this workaround can help others as well.

    1 person found this answer helpful.

  3. Dylan Zhu-MSFT 6,401 Reputation points

    Hi RolandLffler,

    The web browser control works in windows form project. So please confirm if your project is winform project.

    And if it doesn't work, please try to right-click the toolbox, then click "Reset Toolbox".

    Best Regards,

    If the answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our **documentation to enable e-mail notifications if you want to receive the related email notification for this thread.**

  4. Sepehr Estaki 0 Reputation points

    can you solve this problem ? it is 2024 and still can not find webbrowser in toolbox!!!

    0 comments No comments