question

bvobart-tudelft avatar image
0 Votes"
bvobart-tudelft asked JeffSereno-3569 answered

Teams Linux - Cannot login even though authorisation seems to be succesful

Hi everyone!

I'm having a problem logging in with the desktop client of MS Teams on Linux. Whenever I try to login to the app, my username (/email) and password are accepted and it shows me the 2FA page with my organisation's background. I then receive a text message with my 2FA code in it, which I then enter and seemingly gets accepted. I then get the 'Stay signed in?' question, which I answer with 'Yes'. So far so good, I expect the actual MS Teams UI to be launched next. But instead, it closes and relaunches to open the 2FA page again. I don't need to enter my username and password again (unless I manually close and reopen MS Teams), but it does send another text message to my phone with a 2FA code. I can keep entering the 2FA code and then getting the same 'Stay signed in' page and the Teams restart that happens after that, until Teams reaches the limit for maximum amounts of 2FA attempts.

Essentially then, I'm stuck in a 2FA loop, where all of my entered credentials are correct, but somehow it never really logs me in to show the actual app... At least I can still use the in-browser client, but that has its own shortcomings for which I'd like to use the desktop app.

As for some details of my system, I'm running Manjaro KDE (fully up-to-date as of today) with the Teams app installed from the AUR, version 1.3.00.30857 (though this problem has been with me for +- a month now). Interestingly, I was able to use the Teams desktop app from September to October "just fine" (had some problems back then as well, including with login, but that then suddenly 'just worked' iirc)

If there's any other info you need to debug this issue, let me know! What can we do to get MS Teams on Linux working for me? Or is it just a lost cause?

office-teams-linux-itpro
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

SharonZhao-MSFT avatar image
0 Votes"
SharonZhao-MSFT answered SharonZhao-MSFT commented

@bvobart-tudelft,

Does anyone else have the same issue?

Make sure that you have set the correct time zone on your machine.

Then, clear the config folder. The following is a list of locations depending on your type installation:
46092-image.png


If the response is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.




image.png (15.1 KiB)
· 5
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Probably, but I'm not sure.

My timezone is set correctly.

Removing the config folder indeed fixed the issue, I can log in properly now! Something in there must've corrupted somehow. Please note that I didn't install Teams through any of those methods you listed: as I indicated in my question, I installed Teams through the AUR. I found the location of my config folder to be: ~/.config/Microsoft/Microsoft\ Teams (note that the \ is there to escape the space in the path)



1 Vote 1 ·

@bvobart-tudelft
Thanks for your sharing. I'm glad to hear that you have resolved this issue.
Any other questions, it is welcome to go back to discuss with us.
Have a nice day!

0 Votes 0 ·

@SharonZhao-MSFT

Hi it's me again. I'm having the same problem again, but then with a different account and the earlier solution of removing the config folder doesn't fix it anymore. That other account is from another organisation which requires me to use 2FA through the Microsoft Authenticator app. The notification on my phone to approve my login pops up immediately after entering my email and password, as expected, but when I approve it, the same thing happens as in my original post: MS Teams closes and relaunches to open the 2FA page, prompting another 2FA notification from the Authenticator app. When I approve that, the same thing happens again.

Removing the config folder doesn't work this time around (tried that multiple times to no avail), so right now there's no way I can login to MS Teams on Linux with that organisational account That makes it barely usable. What are the responsible team's plans to fix these login issues?

0 Votes 0 ·
Show more comments
JeffSereno-3569 avatar image
1 Vote"
JeffSereno-3569 answered

Had a similar issue in April 2021 with Ubuntu 20.04 LTS. My clock had drifted badly after being switched off for a period of time (possibly a bad RTC battery) and I got the boot loop as well.

Uninstalling and reinstalling didn't fix the issue. In the end, I had to correct the clock and then delete the Microsoft and Teams folders from ~/.config before Teams would login and launch properly (the config folders get recreated automagically).

I have since added a cron job to keep my clock updated properly, ie: "@hourly /usr/sbin/ntpdate ntp.ubuntu.com"

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.