My container-based webapp (AppService) can't make outbound network connections, and there's no way for me to diagnose it

John K 6 Reputation points
2020-12-07T14:14:26.753+00:00

Starting an hour ago my web app (which is a .net core app running on "Webapps for containers") can no longer access our cloud database provider (MongoDB Atlas). I've temporarily tried to allow all IP addresses in Atlas to rule out that as a cause, but it didn't help.

Also tried restarting the app multiple times.

I would really like to get console access to the container, in order to try some curl and ping to see if I can narrow it down. But when I go to the Kudu page and click "bash", I get this error:

45720-bash.png

So right now I'm in a situation where I have no tools to help me figure out the cause of the problem.

Anyone has any tips?

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
7,038 questions
{count} votes

1 answer

Sort by: Most helpful
  1. SnehaAgrawal-MSFT 18,871 Reputation points
    2020-12-08T14:29:42.09+00:00

    Thanks for asking question. If I have understood right, you are having issue while making new outbound connections. If so, you may want to know that the major cause for intermittent connection issues is hitting a limit while making new outbound connections.
    The limits you can hit include:
    • TCP Connections: There is a limit on the number of outbound connections that can be made. The limit on outbound connections is associated with the size of the worker used.
    • SNAT ports: Outbound connections in Azure describes SNAT port restrictions and how they affect outbound connections.

    You may refer to below document link on troubleshooting.

    https://learn.microsoft.com/en-us/azure/app-service/troubleshoot-intermittent-outbound-connection-errors

    Also you can access App Service diagnostics feature. Navigate to your App Service web app container, In the left navigation, click on Diagnose and solve problems.

    App Service diagnostics is an intelligent and interactive experience to help you troubleshoot your app with no configuration required.

    Check: https://learn.microsoft.com/en-us/azure/app-service/overview-diagnostics

    Let us know.