Shared folder permissions confused

Anne 276 Reputation points
2020-12-07T19:51:42.737+00:00

I am using windows server 2019. I understand for shared folders I need to add a user into both shared folder permission and also ntfs folder permission .

Recently I got access denied from a SQL job to write a file into a shared folder since it is a new server, the admin forgot to add some users permission to that folder.

The shared folder for example called \myserver\mydatafolder\

The job is running using account mydomain\jobuser

So since I am one of admins of the server. and I tried to open \myserver\mydatafolder\ from my workstation, then I simply click security tab and add the mydomain\jobuser into that folder, then rerun the job, this time the job succeeded, no longer have access issue.

My question is I thought i need to add both NTFS permission and shared permission, but I only did one of them as above, which I think it is ntfs permission, I did not do even the shared folder permission, why I no longer have access denied issue.

I checked the shared folder security on the server, it is administrator only.

Any ideas?

Thanks

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,049 questions
0 comments No comments
{count} votes

Accepted answer
  1. Fan Fan 15,286 Reputation points Microsoft Vendor
    2020-12-08T02:52:36.397+00:00

    Hi,

    If you create a folder , authenticated users group have the read and execute NTFS permission inherited from the root by default.
    46004-12083.png

    If you share the folder by advanced sharing option ,everyone have the read permission by default.
    46055-12082.png

    If possible, would you please share a screenshot of the NTFS permission assignment and the SHARE permission assignment.(please hide the private information)
    Did the user belong to any groups and the groups have the read permission on the share folder?
    The user access the folder by \servername\shared folder, right?

    1 person found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. Anne 276 Reputation points
    2020-12-11T03:16:43.843+00:00

    Thank you.
    I don't see authenticated user or everyone in the share permission, only administrators.
    But the account I use is not an admin.

    when I add this account to the group from my desktop using \serverrname\myfolder, I think it is adding only ntfs permission, but after that it worked.

    So i am still confused I didnot add the account to share permission, but it still owrks.