Connecting to Windows NT 4.0 from Windows NT through File Explorer now yields "The remote device or resource won’t accept the connection"

JMR Electronics, Inc 1 Reputation point
2020-12-07T18:35:23.917+00:00

I have a Windows 10 Pro x64 desktop, which up until about a week ago has always been able to successfully connect to a Windows NT 4.0 share.

The error message again is:

The remote device or resource won’t accept the connection

Because of the software running on the WinNT box, AMADA, upgrading the box is not possible.

The Windows 10 box has SMB 1.0 client installed. As mentioned, the box up until a week ago was connecting to the NT box with no issues. The Windows 10 box always connected automatically to the shared folder (reconnect at login option selected on File Explorer).

For whatever it is worth, the WinNT box is old enough that it does not have RDP and even more annoying does not have USB support. I suggested to the Win10/WinNT user to use a USB stick. That got a shrug, but that is not an option either. The box is stuck at Windows NT 4.0.

I am able to ping the IP address from the Win10 client just fine. The WinNT box can ping the Win10 box.

The Windows 10 computer is part of a domain, but the WinNT box is too old, so that is part of a workgroup. It has been that way for a while, so this configuration works. Our company's domain controller runs Windows 2019.

There is no antivirus on the Windows NT 4.0 box and I do not think that box has firewall. Either way, everything was working just over a week ago.

Thoughts?

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,595 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Sunny Qi 10,926 Reputation points Microsoft Vendor
    2020-12-08T09:40:38.6+00:00

    Hi,

    Thanks for posting in Q&A platform.

    Based on provided information, my understanding is Windows 10 client cannot access to the shared folder on Windows NT 4.0. Please understand that we do not have such Windows NT 4.0 device for testing in our lab.

    I would suggest you to try if the following methods could help you.

    A. Please run the following command in PowerShell to doble confirm if the SMB 1.0 was enabled on win 10 client.

    Get-WindowsOptionalFeature –Online –FeatureName SMB1Protocol

    B. If the SMB 1.0 was enabled, please try the following steps on Windows 10:

    Open Local Group Policy Editor-->Security Settings-->Local Policies-->Security Options--> find Network Security: LAN Manager authentication level and right click it and select Properties-->select Send LM&NTLM - use NTLMv2 session security if negotiated--> click Apply and OK

    And then please kindly check if the shared folder can be accessed.

    46291-smb.jpg

    C. If the issue still persist, please try to add the user that needs access to the shared folder in the following Group Policy from windows NT 4.0 device side.

    46292-add-user.jpg

    Best Regards,
    Sunny

    ----------

    If the Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    1 person found this answer helpful.
    0 comments No comments

  2. Suporte BCROEE 0 Reputation points
    2023-10-17T14:34:00.4066667+00:00

    perfect. it works

    0 comments No comments