windows athentication mode not working

kobosh 176 Reputation points
2020-12-08T15:07:02.877+00:00

Hi I am following through with Pluralsight tutorial

I create empty webform app and set authentication to windows and deny anonymous users and enable NTLM in properties . But when I run app I am not getting log in pop up like the instructor is getting. I am using windows 10 professional. I open windows as admin.

ASP.NET Core
ASP.NET Core
A set of technologies in the .NET Framework for building web applications and XML web services.
4,141 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Sam Wu-MSFT 7,036 Reputation points Microsoft Vendor
    2020-12-10T08:09:19.63+00:00

    Hi @kobosh ,

    Are you using Internet Explorer? It may be that browser is configured to auto logon as anonymous. The browser has to be set to authenticate as the logged on user. you can change it by in the browser.

    settings | Internet options | Security | Local intranet | Custom level | user authentication | Prompt for user name and password

    46863-12.png


    If the answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments