Winscp doesnt work when run as execute process task from SSIS Package

bk 451 Reputation points

Hi All
I have a winscp script which when i run from the winscp command line , copies the files from the sftp server to the local drive and deletes the files from the sftp server. When i run the winscp script as execute process task , i do not get any error message, just a command prompt window pops up for a brief second and disappears and none of the files get copied over. Please advice. As there is no error message i do not know where to start looking for.


SQL Server Integration Services
SQL Server Integration Services
A Microsoft platform for building enterprise-level data integration and data transformations solutions.
2,311 questions
0 comments No comments
{count} votes

1 additional answer

Sort by: Most helpful
  1. Yitzhak Khabinsky 24,011 Reputation points

    The preferred approach is to use WinSCP in SSIS Script Task.

    It is documented here: Using WinSCP .NET Assembly from SQL Server Integration Services (SSIS)