Hyper V VM stuck on Starting

Mark Dagley 1 Reputation point
2020-12-08T21:29:07.33+00:00

Hi I have a Windows 2019 Box with 1 VM on it that is being replicated by Veeam to a secondary Server.

when we shut down the VM on the primary server it will get stuck for a long time by which i mean 40 minutes or more on staring.
there is no significant Disk or CPU activity and nothing shows in the event log.

the replicate will boot fine.

Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,530 questions
0 comments No comments
{count} votes

5 answers

Sort by: Most helpful
  1. Dave Patrick 426K Reputation points MVP
    2020-12-08T23:59:11.923+00:00

    Might try copying the secondary VHD to primary for a test.

    --please don't forget to Accept as answer if the reply is helpful--

    0 comments No comments

  2. Mark Dagley 1 Reputation point
    2020-12-09T11:05:20.6+00:00

    Disk space will not allow me to do that however I did create a second VM on the host that had the issue and even with No OS installed it took the same amount of time to start so safe to say the issue is with the host.

    0 comments No comments

  3. Dave Patrick 426K Reputation points MVP
    2020-12-09T14:05:27.997+00:00

    Ok, well no event logs, so I'd check that its patched fully. Check health
    sfc /scannow
    dism /online /cleanup-image /restorehealth

    Without any clues the simplest thing may be to rebuild it, patch fully, add hyper-v role, import the VM

    --please don't forget to Accept as answer if the reply is helpful--

    0 comments No comments

  4. Xiaowei He 9,866 Reputation points
    2020-12-10T06:11:30.45+00:00

    Hi,

    Please check the performance of the host when we start a VM, if the CPU, memory, or disk usage is high?

    Please check if we are running any third-party anti-virus application on the host, if yes, please uninstall it.

    As a test, we may try to export the VM, then uninstall the Hyper V role on the host, make the host's system and firmware up to date, then reinstall the Hyper V role, and import the VM, check if the issue could be resolved.

    Thanks for your time!
    Best Regards,
    Anne

    -----------------------------

    If the Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  5. Mark Dagley 1 Reputation point
    2020-12-14T08:45:15.043+00:00

    Going to try uninstalling an reinstalling the Hyper V role but production system so waiting for a maintenance window.