azure devops agent(in azure storage account shile share) can not access local device folder

현균 박 41 Reputation points
2020-12-09T04:47:18.627+00:00

Hello

i tried Azure DevOps Pipeline Service..

i located my agent in Azure file share and My file share system is configured on a virtual network.

My agent would have to access the files on the local machine and save the output on the local machine.

but when i run pipeline. i got Error like this.

C:\windows\system32\cmd.exe /D /S /C ""C:\Program Files (x86)\Microsoft SDKs\Azure\CLI2\wbin\az.cmd" account
set --subscription 47ea9324-4b4e-4b27-9452-1ab198b2a7a2"
C:\windows\System32\WindowsPowerShell\v1.0\powershell.exe -NoLogo -NoProfile -NonInteractive -ExecutionPolicy > Unrestricted -Command ". 'Z:\agent_work_temp\azureclitaskscript1607488087137.ps1'"
. : AuthorizationManager check failed.
At line:1 char:3

  • . 'Z:\agent_work_temp\azureclitaskscript1607488087137.ps1'
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  • CategoryInfo : SecurityError: (:) [], PSSecurityException
  • FullyQualifiedErrorId : UnauthorizedAccess

[error]Script failed with exit code: 1

Is there any way to solve it?

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
35,811 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Leon Laude 85,646 Reputation points
    2020-12-09T08:58:19.333+00:00

    Hi anonymous user,

    Azure DevOps is currently not supported in the Q&A forums, the supported products are listed over here https://learn.microsoft.com/en-us/answers/products (more to be added later on).

    You may ask the experts in the dedicated Azure DevOps forum over here:
    https://developercommunity.visualstudio.com/spaces/21/index.html

    ----------

    (If the reply was helpful please don't forget to upvote and/or accept as answer, thank you)

    Best regards,
    Leon

    0 comments No comments