Intune Configuration Policy - Maximum Minutes of Inactivity Until Screen Locks (Windows 10)

CIS03 51 Reputation points
2020-12-09T18:58:21.607+00:00

I am trying to push out a policy to lock the Windows 10 devices after they have been inactive for 15 minutes. I have pushed out a test policy to my device to lock after 1 minute. I can see that the policy was applied to my device, but it does not lock the screen.

Has anyone else noticed that this policy does not work even if it says that it was applied?

Does anyone know if there is a way to resolve it, or do we have to wait for an update from Microsoft?

My computer is fully updated on Windows 10 (Version 20H2 with all cumulative updates).

Microsoft Intune Configuration
Microsoft Intune Configuration
Microsoft Intune: A Microsoft cloud-based management solution that offers mobile device management, mobile application management, and PC management capabilities.Configuration: The process of arranging or setting up computer systems, hardware, or software.
1,698 questions
{count} votes

Accepted answer
  1. Lu Dai-MSFT 28,331 Reputation points
    2020-12-10T02:26:30.93+00:00

    @CIS03 Thanks for posting in our Q&A. From your description, I know that a screen lock policy is deployed to the windows 10 device successfully, but it doesn’t work. If there is any misunderstanding, feel free to let us know.

    For this issue, I have done the test in my lab. Here are the details for the reference.

    1. Create a custom profile and deploy this profile to the group you want.
      Name: ScreenLock
      OMA-URI: ./Device/Vendor/MSFT/Policy/Config/DeviceLock/MaxInactivityTimeDeviceLock
      DataType:Integer
      Value: 1 (Value in minutes you want)
      46784-image.png
    2. When the deployment status of this profile is succeeded, restart the devices that you assigned.
    3. Wait a minute, and we can find that the screen is locked.

    Given the situation, we suggest to restart the affected device and check again to see if the screen will be locked.

    Hope it can help.


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    5 people found this answer helpful.
    0 comments No comments

3 additional answers

Sort by: Most helpful
  1. Jon 11 Reputation points
    2022-09-07T16:58:25.707+00:00

    To add to this confusing situation. The exact setting in Endpoint Manager, under "Configuration profiles > Device Policy for Windows 10 -> configuration settings -> password" you'll notice "Maximum Minutes of Inactivity Until Screen Locks" and it may have a setting. This whole policy isn't configured on our setup, we do it elsewhere. However, even though this isn't configured, the fact a value is in there overwrites settings from group policy or locally set. I hope this isn't too far off topic, but it was a pain to track down, as I said, the policy isn't even set. I had to change it to not configured for it to go away.

    It did solve my issue with the laptops going to sleep.

    238708-screen-lock-issue.png

    2 people found this answer helpful.
    0 comments No comments

  2. CIS03 51 Reputation points
    2020-12-10T14:37:14.263+00:00

    @Lu Dai-MSFT , thanks for the response. I think your solution would have worked. However, I was unaware of the reboot being required. After I booted up my computer this morning my original screen timeout policy was applied.


  3. Flavia.Admin 25 Reputation points
    2023-11-13T17:21:03.6166667+00:00

    I have all these policies from the previous IT team. How do I know which is the one that has the screen lock time set up?

    User's image