MS Teams - Authenticator not sending code

Shailesh Patel 6 Reputation points

I have Teams for Mac and MS Authenticator installed on iPhone.

I am able to log into Teams but when I switch organizations it asks me to sign in. I enter my email and password and then am presented with a Microsoft dialog box: "Please type in the code displayed on your authenticator app from your device"

I type the code on my iPhone Authenticator app and it says "You didn't enter the expected verification code. Please try again. View details"

Error Code: 500121
Request Id: 2a42ec34-9bb1-4274-aa7b-16b91729d200
Correlation Id: 8dc28f78-92cd-4876-ac77-25625483caed
Timestamp: 2020-12-10T12:46:44Z

I have tried to Sign in another way as well.

Microsoft Teams
Microsoft Teams
A Microsoft customizable chat-based workspace.
9,587 questions
Microsoft Authenticator
Microsoft Authenticator
A Microsoft app for iOS and Android devices that enables authentication with two-factor verification, phone sign-in, and code generation.
6,096 questions
0 comments No comments
{count} vote

2 answers

Sort by: Most helpful
  1. Tony Norcross 11 Reputation points

    I have exactly the same problem using my business account (email) to sign into Azure (not Office365). I just have no access to Azure it at all. Very frustrating, as I can't offer/develop Azure AD for clients. Even the numeric code generated with Authenticator isn't recognized. Despite removing Authenticator as a 2FA, I still get asked to approve via the app and never get a notification. I've tried removing the app, clearing the cache, re-adding accounts, different phones... it's so secure, even I can't access Azure any longer.

    2 people found this answer helpful.
    0 comments No comments

  2. JimmyYang-MSFT 50,446 Reputation points Microsoft Vendor

    Hi @Shailesh Patel ,

    Do you mean you have typed the verification code you received but cannot sign in Teams client?

    Does this issue happen in Teams desktop client or Web client?

    According to your description, it seems you have enabled 2FA in Office 365. In this case, we recommend you try to follow these steps to disable multi-factor authentication:

    1. Go to the Office 365 admin center.
    2. Go to Users > Active users.
    3. Click on Multi-factor authentication tab option (in new admin center).
    4. Select your user
    5. Click Disable on the right side.

    For more reference:

    If the response is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.