BSOD on virtualization enabled

Liquid Self 21 Reputation points
2020-12-10T13:40:18.933+00:00

Hi there!

I've got:

-HP Pavilion - 15-ec1026ur,

-Windows 10 pro installed from scratch,

-Newest bios update. (F.11)

-Enabled Virtualization in bios.

I do:

Start > Turn Widnows features on or of > Hyper-V Hypervisor mark placed.

Then windows requires restart to install new features, after restart I'm getting SYSTEM_THREAD_EXCEPTION_NO_HANDLED bsod screen.

I tried to analyze my Minidump and the rtwlane.sys file was mentioned there. Google says that rtwlane.sys is a driver file.
I tried to disable network adapter

This one image.png

And bsod is gone... as well as internet connection of course.
Also bsod disappears if I disable virtualization in bios or unmark Hyper-V Hypervisor.

I tried to update/rollback bios and network adapter driver. Doesn't help.

What can I do about it? Seems like I need virtualization, and to work internet together some how.

Now I can't use software like docker.

Here is my Minidump file https://1drv.ms/u/s!AtNz1xl8i5ePgnAI6m8HRoaIxnbe?e=PiFXqY

Help! Thanks!

Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,530 questions
0 comments No comments
{count} votes

Accepted answer
  1. Andrei Corovin 101 Reputation points
    2021-04-02T19:28:19.027+00:00

    Hello,

    Here is the analysis of your mini-dump:

    Debug session time: Mon Dec  7 11:00:40.020 2020 (UTC - 4:00)  
    Built by: 19041.1.amd64fre.vb_release.191206-1406  
    System Uptime: 0 days 0:00:02.700  
    BugCheck Info: [SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (7e)][1]  
    Bugcheck code 0000007E  
    Arguments:   
    Arg1: ffffffffc0000005, The exception code that was not handled  
    Arg2: fffff8069953b476, The address that the exception occurred at  
    Arg3: fffffc0f1e918218, Exception Record Address  
    Arg4: fffffc0f1e917a50, Context Record Address  
    PROCESS_NAME:  System  
    Probably caused by: rtwlane.sys ( rtwlane+b476 )  
    FAILURE_BUCKET_ID:  AV_rtwlane!unknown_function  
    BiosVersion = F.11  
    BiosReleaseDate = 07/22/2020  
    SystemManufacturer = HP  
    SystemProductName = HP Pavilion Gaming Laptop 15-ec1xxx  
    BaseBoardProduct = 87B2  
    
    3: kd> lmvm rtwlane  
    Browse full module list  
    start             end                 module name  
    fffff806`99530000 fffff806`9a08b000   rtwlane    (no symbols)             
        Loaded symbol image file: rtwlane.sys  
        Image path: \SystemRoot\System32\drivers\rtwlane.sys  
        Image name: rtwlane.sys  
        Browse all global symbols  functions  data  
        Timestamp:        Thu Jun  4 01:35:02 2020 (5ED88806)  
        CheckSum:         00B35C08  
        ImageSize:        00B5B000  
        Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4  
        Information from resource tables:  
    

    Try to update the network drivers - Realtek PCI-E Wireless LAN NIC NDIS Driver

    fffffc0f`1e918450 fffff806`9957132e : 00000000`00000000 fffff806`99560a0a fffff806`4b787541 ffffdc0d`2f06c1a0 : rtwlane+0xb476  
    fffffc0f`1e918480 fffff806`99578b08 : ffffdc0d`2f600000 00000000`000000ff ffffdc0d`2f49b000 00000000`00000000 : rtwlane+0x4132e  
    fffffc0f`1e918510 fffff806`99572e03 : ffffdc0d`2f600000 fffffc0f`1e9186a0 00000000`00000000 fffffc0f`1e91869c : rtwlane+0x48b08  
    fffffc0f`1e918580 fffff806`9958612d : ffffdc0d`2edb5c02 fffffc0f`00000000 ffffdc0d`2f2ecbd8 ffffdc0d`2f2ec410 : rtwlane+0x42e03  
    fffffc0f`1e918650 fffff806`9a0ccb6d : ffffdc0d`280c8000 ffffdc0d`2f445000 00000000`00000057 00000000`00000000 : rtwlane+0x5612d  
    fffffc0f`1e9187b0 fffff806`9a0ce4cf : 00000000`00000000 ffffdc0d`2f445000 fffff806`9a16c040 00000000`00000000 : wdiwifi!CMiniportInitializeJob::PerformAllocateAdapter+0xf1  
    fffffc0f`1e918900 fffff806`9a0c248e : ffffdc0d`2f445000 00000000`00000000 ffffdc0d`2f440328 00000000`00000000 : wdiwifi!CMiniportInitializeJob::OnJobStarted+0x7f  
    fffffc0f`1e918950 fffff806`9a0c2302 : ffffdc0d`2f438401 00000000`00000000 ffffdc0d`2f440328 00000000`0000000d : wdiwifi!CJobBase::OnStartJobEventHandler+0x17e  
    fffffc0f`1e9189b0 fffff806`9a0bd611 : ffffdc0d`2f440328 ffffdc0d`2f4384f0 ffffb600`87401180 fffff806`6026c7a4 : wdiwifi!CJobBase::OnEventQueueCallback+0x32  
    fffffc0f`1e9189e0 fffff806`9a0be2c4 : ffffdc0d`2f440330 00000000`00000000 fffff806`9a16c040 00000000`00000000 : wdiwifi!EventQueue::ProcessEventQueueUntilEmpty+0x165  
    fffffc0f`1e918a50 fffff806`9a0acc13 : ffffdc0d`2f3eecf0 ffffdc0d`2ebf1d90 ffffdc0d`2f3eed60 fffff806`6026dae8 : wdiwifi!EventQueue::OnWorkItemCallback+0x74  
    fffffc0f`1e918a90 fffff806`617bc6a7 : ffffdc0d`2ebf1d90 ffffdc0d`2f3eecf0 00000000`00000000 00000000`00000100 : wdiwifi!CWdfWorkItemContext::s_WdfWorkItemCallback+0x43  
    fffffc0f`1e918ac0 fffff806`6035a435 : ffffdc0d`2f3351a0 ffffdc0d`2f335100 ffffdc0d`2eb87dc0 fffff806`617bc5c0 : Wdf01000!FxWorkItem::WorkItemThunk+0xe7  
    fffffc0f`1e918b00 fffff806`60225975 : ffffdc0d`2ac68080 ffffdc0d`2ac68080 fffff806`6035a300 ffffdc0d`00000000 : nt!IopProcessWorkItem+0x135  
    fffffc0f`1e918b70 fffff806`60317e25 : ffffdc0d`2ac68080 00000000`00000080 ffffdc0d`27cfa040 000f8067`b8bbbdff : nt!ExpWorkerThread+0x105  
    fffffc0f`1e918c10 fffff806`603fcdd8 : ffffb600`87401180 ffffdc0d`2ac68080 fffff806`60317dd0 00000000`00000000 : nt!PspSystemThreadStartup+0x55  
    fffffc0f`1e918c60 00000000`00000000 : fffffc0f`1e919000 fffffc0f`1e913000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x28  
    

    Also I see you are using Kaspersky Antivirus. Have you tried to reproduce the problem without Kaspersky Anti-Virus?

    1 person found this answer helpful.

2 additional answers

Sort by: Most helpful
  1. Carl Fan 6,836 Reputation points
    2020-12-11T07:44:46.617+00:00

    Hi,
    Some people have the same problem. According to the dump information, it is related to your network card driver. Disable it, bsod will go but could not connect the internet. I seen you have tried to update driver, but I'm afraid that you need to check the video card manufacturer's official website. Try the latest version video card driver or an older driver to check if it will compatible.
    Some people used a USB WAN adapter could be work.
    Otherwise, wait for new driver or downgrade the system version.
    Hope this helps and please help to accept as Answer if the response is useful.
    Best Regards,
    Carl

    1 person found this answer helpful.
    0 comments No comments

  2. A B 1 Reputation point
    2021-12-06T07:51:55.997+00:00

    Just disable "Realtek pcie gbe family controller" from Device Manager and reboot with Virtualization Enabled in the BIOS. On a Ryzen 7/HP/Windows 11 Home machine this worked for me after troubleshooting with various google solutions for 10 hours. HP will not help because this is not considered a hardware issue that is covered by their limited warranty on new machines - software issues are not covered per their support. Wow!

    1. Update all drivers via the machine manufacturer's website (not windows update as windows does not always detect old drivers).
    2. Install the latest driver for your GPU - Intel/AMD/Nvidia
    3. Disable "realtek pcie gbe family controller" from Device Manager. You don't need this anyways if you connect over wifi.
    4. Reboot with Virtualization Enabled in the BIOS
    5. Update to PowerShell 7.2
    6. switch to wsl 2 (from powerShell in admin mode)
    7. Install Ubuntu or Ubuntu LTE (from power shell in admin mode)
    0 comments No comments