OST file is not created in VHDX container

DEHEIJBarry-7144 1 Reputation point
2020-12-10T14:53:30.367+00:00

As the title says the OST is not being created. We deleted the container, created a new outlook profile (multiple times), no error at starting Outlook for wrong OST file. When disabling FSLOGIX the OST gets created, but if we enable FSLOGIX and delete the OST no new OST is getting created.

Also the different logs doesn't show error warnings.

We implemented the newest FSLOGIX and that is also not fixing this issue. What is the next step?

FSLogix
FSLogix
A set of solutions that enhance, enable, and simplify non-persistent Windows computing environments and may also be used to create more portable computing sessions when using physical devices.
463 questions
{count} votes

5 answers

Sort by: Most helpful
  1. Fredrik Endresen 91 Reputation points
    2020-12-22T14:01:30.453+00:00

    One more thing. If you look into the registry of one of the users when logged in.

    Here:
    .\Software\Policies\Microsoft\office\16.0\outlook\cached mode\

    Is there a DWORD value there with the name "cachedexchangemode"?

    If yes - what value has it?

    That is the value that actually sets Outlook in cached mode.
    (The FSLogix "OutlookCachedMode" setting will do this, BUT it will NOT override any other GPO`s that also sets this value.)

    1 person found this answer helpful.
    0 comments No comments

  2. Fredrik Endresen 91 Reputation points
    2020-12-13T23:32:21.83+00:00

    Hi!

    I guess you have changed the default location of the .ost file in the office\outlook GPO:

    Microsoft Outlook 2016/Miscellaneous/PST Settings
    Default location for OST files Enabled

    Disable this setting, and the .ost file will be created at the default location in the FSLogix container:
    %LOCALAPPDATA%\Microsoft\Outlook

    Regards
    Fredrik

    0 comments No comments

  3. Arjen 1 Reputation point
    2020-12-15T11:26:26.577+00:00

    Hi!

    I'm a colleague of Barry. We both are looking into this problem.
    The mirror OST to VHD setting was set to 2. Tried it with the 0 setting but this doesn't create the OST

    Also the Default location for OST files setting was not configured. I set it to disabled but no OST is created yet.

    The problem seems to be triggerd after the FSLogix container is deleted and recreated.
    I did this with my test account which was working fine.
    Now I have the same issue. No OST is created. Very strange.
    In the latest Citrix golden image I updated FSLogix to the latest version 2.9.7621.30127
    No difference in behavior for the OST sadly.

    If you have more suggestions, they are very welcome.

    Regards,

    Arjen Zevenbergen

    0 comments No comments

  4. Fredrik Endresen 91 Reputation points
    2020-12-18T22:00:49.887+00:00

    Hi,

    1. Are you using Profile disk only, or both Profile and O365?
    2. When .OST was created initially - where was it created - path? \AppData\Local\Microsoft\Outlook ?
    3. A screenshot of the registry would help. Both

    HKEY_LOCAL_MACHINE\SOFTWARE\FSLogix\Profiles

    and

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\FSLogix\ODFC (if O365 profiles are used..)

    Regards
    Fredrik

    0 comments No comments

  5. Arjen 1 Reputation point
    2020-12-22T13:21:20.133+00:00

    Hi Fredrik,

    1. We are only using the O365 container
    2. It was indeed created at the default location \AppData\Local\Microsoft\Outlook

    50455-2020-12-22-14-19-07.png

    Regards,

    Arjen

    0 comments No comments