Unable to Create New List from Existing List

Jennifer L. VanderVeen 11 Reputation points
2020-12-11T16:23:07.483+00:00

When in Microsoft Lists (both in the standalone site and on my Teams tabs) when I try to create a list from an existing list, after going through the steps and selecting the Team to save to, I get the following error message “Action 1 (createSPList) is invalid. List subaction 14 (addSPLookupFieldXml) is invalid. Parameter targetListName has an invalid value”

I have tried the creation process with every List I have and have tried editing the name a million different ways and I cannot get it to save.

This is a critical part of our client workflow and I need it to work reliably. Especially when the Import from Excel feature also isn’t working.

SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
9,866 questions
{count} votes

5 answers

Sort by: Most helpful
  1. Elsie Lu_MSFT 9,771 Reputation points
    2020-12-14T06:39:21.947+00:00

    Hi @Jennifer L. VanderVeen ,

    Does this error message appear when using workflow? Would you like to share the steps of your workflow? Screenshots will be very helpful.

    • I would suggest you try to check the list name and lookup field of your list, per my understanding somewhere may contain unsupported characters, because the error says: Parameter targetListName has an invalid value.
    • You mentioned you have tried every list, are you testing in the same list?Could you please describe what tests were done?
      47765-3.jpg
    • I have checked your other posts and I’m wondering if this error is related to the previous error message.
      Per my test using Import from Excel feature, I create two testbooks with the same contents(â€₵), when the name is â€₵, the previous error occurs and when the name is Book1 there is no error, so you may check if these errors are due to unsupported characters:

    47814-2.jpg
    When the name is â€₵:
    47815-capture.jpg
    When the name is Book1:
    47816-1.jpg


    If the answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. misbips02 1 Reputation point
    2020-12-22T01:41:31.03+00:00

    I got this same error just now and it was because of a lookup column on the list. I had remove it and then it worked. I had added the related issues column.

    0 comments No comments

  3. Roberto Rodriguez 1 Reputation point
    2022-03-10T20:58:28.077+00:00

    Hello, I had the same error. It's because the source list has a lookup field, so I deleted that field just to create the new list and I added the field again in the source list. I you have data added I recommend you to backup and upload.


  4. Gladys Aguilera 21 Reputation points
    2022-12-08T17:07:13.927+00:00

    Hi
    apparently it has a row limit
    mine came out with an error saying the limit is 300 rows
    is that possible ?

    0 comments No comments

  5. Dallas Schwab 0 Reputation points
    2023-05-08T11:52:33.4533333+00:00

    everyday i lower my standards for MS and they keep finding ways to reach under the eversinking bar. Why is this error not something useful like"you have a look up field, cant copy that" instead of this gibberish. Gobsmackingly simple tasks become impossible everytime I reach to use SharePoint

    0 comments No comments