Hyper-V General Access Error

Michael R. Emmert 121 Reputation points
2020-12-11T17:26:16.17+00:00

A while back, I installed a Hyper-V VM, running on a Windows 2016 host-server. The VM is running Ubuntu. In the configuration, two separate physical hard drives are allocated to this VM to run it's application. Those hard drives are off-line to the Host-server. This has been working very well for almost a year.

Due to another project, I needed to upgrade the Host-server to Windows 2019. I performed an in-place installation and everything appeared to be working.

However, when I attempt to start the Ubuntu VM, I receive an error: Hyper-V Virtual Machine Management service Account does not have permission to open attachment ... <information of harddrive ID given> ... Error:'General access denied error'.

My knowledge of Hyper-V is via being self-taught. An internet search has not provided an obvious answer.47512-hyper-v-error.jpg

Any specific help would be muchly appreciated.

Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
1,935 questions
No comments
{count} votes

3 additional answers

Sort by: Most helpful
  1. Michael R. Emmert 121 Reputation points
    2020-12-13T16:31:44.87+00:00

    Yes, I have, to no effect.
    I'm afraid It may be necessary to rebuild everything. That scares me because that would mean the loss of my data.


  2. Mico Mi 1,901 Reputation points
    2020-12-14T03:11:17.913+00:00

    Hi,
    I met the similar issue several times when I tried to start my VM.
    My solution is to run the following cmd to grant the full control permission to the VM:
    icacls "path of your file" /grant "NT VIRTUAL MACHINE\VM ID":(F)
    I hope it could help at your side!
    Thanks for your time!
    Best Regards,
    Mico Mi

    -----------------------------

    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

  3. Michael R. Emmert 121 Reputation points
    2020-12-15T22:13:38.11+00:00

    Happy news. I have solved my problem. I disconnected the drive from my VM. Created a new VM and attached the drive. Because the VM OS was present, the new VM started up with no problems. Then I shut down the new VM and re-attached the hard drive to the problem VM. The drive was accepted, and the VM powered up.

    After that, the only thing I needed to change was to re-enter the VM's IP address, mask, gateway, and DNS servers.

    Currently, everything is working just fine.

    Thank you, everyone for the ideas and suggestions. They proved helpful in my journey toward a solution.