SQL server 2019 developer edition installation error

Bashar Kheir 1 Reputation point

hello i tried to install SQL server 2019 developer and SQL server 2017 developer editions and SSMS and i'm always getting this error

there is a problem with this windows installer package . A DLL required for this installation to complete could not be run . Contact your support personnel or package vendor.

my laptop is lenovo legion 5 64-bit processor core i7 and 64-bit os i tried providing permission full control to everyone in temp folder and i tried removing all c++ runtimes and nthg worked for me
always when the setup reach install_sqlncli_Cpu64_Action it returns false and the setup fails

SQL Server
SQL Server
A family of Microsoft relational database management and analysis systems for e-commerce, line-of-business, and data warehousing solutions.
11,003 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Alvaro Sanchez 1 Reputation point


    Post summary log, please. Maybe installation package is corrupted or the issue is related with .NET Framework version.


  2. Erland Sommarskog 88,546 Reputation points

    You find installation logs in C:\Program Files\Microsoft SQL Server\150\Setup Bootstrap\Logs where there is one folder for each installation attempt. It is probably the file for SQLncli you look in. Maybe there is a hint which DLL that is missing. (Although I have feeling that it is not - this error seems familiar.)

    0 comments No comments

  3. AmeliaGu-MSFT 13,931 Reputation points Microsoft Vendor

    Hi @Bashar Kheir ,

    Could you please share us SQL Server Setup log within %programfiles%\Microsoft SQL Server\nnn\Setup Bootstrap\Log? (nnn=150 for SQL Server 2019, 140 for SQL Server 2017). Please refer to View and Read SQL Server Setup Log Files.

    And please make sure you have enough permission on “C:\Users\username\AppData\Local\Temp” folder.

    In addition, according to my research, this error may be related to sqlncli.msi. Here is a solution from this blog. On opening the sqlncli.msi file using ORCA editor and searching for SNAC_SetClientSSNLDefaults_32 key, and then change the value $DP_sqlncli11_dll_32 = 3. Please check if this solution is suitable for your issue.

    Best Regards,

    If the answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.