Microsoft endpoint configuration manager. error "Failed verifying schema version property in wmi sequence"

Mario Alves 26 Reputation points
2020-12-17T08:40:56.21+00:00

Hello,
I don't know if i am at the good place, sorry about it,
We have some problems editing our Task sequence on Microsoft Endpoint Configuration manager (1910),

At this moment we have 12 Task Sequence, on 2 of them, we keep having a lot of errors when we try to edit it :
Prod Windows 10 build 1909 (total Steps 976) and xdev Windows 10 build 1909 (same as prod, but we do some test on it before applying the changes)

Starting 2-3 months ago, we started having this error message when editing, if we add some new steps this problem comes more and more until we can't add anymore a a new step or edit the task sequence.

49036-error-ccm-console2.png

Log file (SMSProv.log) :
49081-2020-12-17-090502.jpg

The only way to edit the task sequence is to restart the WMI service, then for 2-3 minutes it work and then the error come back again.

If we try to re apply again the task sequence, on my computer there is this error, on the main server the CCM console crash and I need to start the Configuration manager again :
49010-error-ccm-console3.png

If we remove some steps the task sequence seems to be stable again, but if you add some new steps, then the error come back again, there is what I tried until now without any success :

48927-tssize.jpg

Does somebody have an idea how to solve this error ? It's really annoying and I would avoid to recreate a full new task sequence from 0... all the others Task sequence are working correctly, they all have 400 - 700 steps and when we edit them there is no error with them.

Thank you in advance for your help and the time you take to read all the message.

Operations Manager
Operations Manager
A family of System Center products that provide infrastructure monitoring, help ensure the predictable performance and availability of vital applications, and offer comprehensive monitoring for datacenters and cloud, both private and public.
1,419 questions
Microsoft Configuration Manager Deployment
Microsoft Configuration Manager Deployment
Microsoft Configuration Manager: An integrated solution for for managing large groups of personal computers and servers.Deployment: The process of delivering, assembling, and maintaining a particular version of a software system at a site.
915 questions
{count} vote

4 answers

Sort by: Most helpful
  1. Simon Ren-MSFT 30,681 Reputation points Microsoft Vendor
    2020-12-18T08:12:34.577+00:00

    Hi,

    Thanks for posting in Microsoft MECM Q&A forum.

    As the TS editor does not save the task sequence to the site database directly; instead, it initiates a WMI call to the SMS Provider , which will then write the data to the site database. For a very large and complex task sequence, the WMI call can cause the WMI process hosting the TaskSequenceProvider to exceed its memory quota. So we can try the following actions:

    1.Increase the available number of WMI memory buffers.
    2.Adjusting the Site Server's WMI Provider handles and Memory allocations.

    For more detailed steps, please refer to this similar thread:
    Task Sequence Error

    Best regards,
    Simon


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. Mario Alves 26 Reputation points
    2020-12-18T08:23:59.977+00:00

    Hello,
    Thank you a lot for your feedback, as mention on my first reply I already tried this solution on the Site Server without any success.

    The registry settings :
    49358-wmi-memory.jpg
    The WMI settings :
    49462-wmisettings.jpg

    Does i also need to apply them on the main SQL server ?

    Regards


  3. Mayer Rene 1 Reputation point
    2021-01-14T09:47:06.947+00:00

    Any news on this topic? We are facing this issue too.

    0 comments No comments

  4. Mario Alves 26 Reputation points
    2021-01-14T11:53:42.2+00:00

    Hello,
    From my side, I have no news, unfortunately, I need to see if we have the contract with Microsoft to open a ticket with the support,

    For the moment the only work around I have is to restart the WMI then for 1-2 minutes I can edit the Task sequence, I tried to reduce the amount of steps on the Task sequence it seems to help, I have a copy of the same task sequence with only 500 steps and I have no issue with this one, the other with the problem have 780-820 steps.

    I was thinking about our anti virus, we are using Cybereason and with Windows 1909 we had some issues with the Powershell and WMI related to the anti-virus who blocks the process and makes it unusable.

    Maybe it's also the Antivirus who does something on the server when there is a lot of data, we have a new version we are testing, if it's simply that I will tell you, I don't know if you are using the same software.

    Have a nice day.