Azure concierge sandbox failure?

Sam Chilwan 21 Reputation points
2020-12-17T14:40:26.81+00:00

Is there an issue with the Azure Sandbox as getting this error

"You do not have any Azure subscriptions in the Microsoft Learn Sandbox directory. Click here to switch to another directory."  

Seems to be persistent. Worked this morning and then suddenly the concierge subscription stopped working. Was using 3/10 of the sandbox so didn't reach the limit

Was working through this training when it happened: https://learn.microsoft.com/en-gb/learn/modules/connect-an-app-to-azure-storage/4-exercise-create-storage-account?source=learn

The AZ Cloud Shell (CLI) within the training is also unable to find a subscription, error shown:

No valid subscriptions found  
You need an Azure subscription to use Azure cloud Shell.  

So bit of a blocker at present, would have switched subscription where I have some credits and tried to work through the exercises. But without a working command line, kind of buggered.

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
35,941 questions
0 comments No comments
{count} votes

8 answers

Sort by: Most helpful
  1. Rob Hall 56 Reputation points
    2021-03-09T17:37:38.213+00:00

    Came across this issue today. Rather than wait for the sandbox environment to expire, I started another learn path exercise and it asked me if I wanted to terminate the existing sandbox and start a new one. I chose to start a new one and it removed the old sandbox. I finished the exercise and returned to the original one and it started a new sandbox successfully.

    11 people found this answer helpful.

  2. deherman-MSFT 33,216 Reputation points Microsoft Employee
    2020-12-17T17:05:28.18+00:00

    @Sam Chilwan

    If you are facing issues in using sandbox while learning on Microsoft Learn, you can report sandbox related issues in below document > Report feedback > Product or functionality > Sandbox issues

    https://learn.microsoft.com/en-us/learn/support/troubleshooting

    You can try changing your directory by clicking on your profile and then change directory and select Microsoft Learn Sandbox.

    3 people found this answer helpful.
    0 comments No comments

  3. Sam Chilwan 21 Reputation points
    2020-12-17T17:30:10.363+00:00

    Thanks @deherman-MSFT , i did originally change the directory from the learn sandbox to my MSDN one and then back to the learning one but that didn’t resolve the issue. Wasn’t sure if it was a current issue with azure learning platform or just me.

    I have reported it based on the link you provided. Hopefully it will sort itself out by tomorrow.

    1 person found this answer helpful.
    0 comments No comments

  4. Sam Chilwan 21 Reputation points
    2020-12-17T18:12:00.483+00:00

    Looks like the other sandbox had to timeout / expire and was able to recreate a new one. That seems to have worked for me.

    0 comments No comments

  5. Frank Abdoelhafiezkhan 1 Reputation point
    2021-01-16T22:13:58.337+00:00

    same issue is also not working for me in te sandbox

    0 comments No comments