Azure domains Advanced Management portal - can't change nameservers

Oliver 96 Reputation points
2020-12-17T15:56:32.87+00:00

I purchased a domain through the Azure Portal and, needed to add a txt record, I assumed I had to go to the advanced management portal. It informed me that the DNS servers weren't ones that would allow me to manage the domain, so I reset them back to their defaults (which appear to be ns01.domaincontrol.com and ns02.domaincontrol.com).

However, that broke everything for me I later discovered; it turns out I could have added the txt record without having gone to the advanced management portal at dcc.secureserver.net. Not to worry, I can just set the nameserver back right?

Wrong. I can't change them to anything and get an error stating that an unexpected error has occurred. Which means I cannot change the nameservers back to the Azure ones. Madness!

Does anyone have any ideas?

49242-dns1.png
49261-dns2.png

Azure App Services
Azure App Services
A feature of Azure App Service used to create and deploy scalable, mission-critical web apps.
4,324 questions
Azure DNS
Azure DNS
An Azure service that enables hosting Domain Name System (DNS) domains in Azure.
395 questions
{count} votes

Accepted answer
  1. Oliver 96 Reputation points
    2021-01-04T12:47:42.997+00:00

    (Sorry for not replying earlier - we all disappeared for Christmas!)

    Will reply publicly here in case anyone else comes across it - I managed to resolve this but I am not entirely sure how or why.

    I think it may have been extraneous periods (.) after the nameservers that were entered originally, but I was reasonably sure that I had tried that initially. Nevertheless, it seems to work when I tried it again without them - so it may have been the other portions of the name servers that I had entered incorrectly.

    The only feedback I'd then give is that the error message of an unexpected error occurring didn't really say much more than that!

    Cheers!

    Oliver


0 additional answers

Sort by: Most helpful