AzureAD Connect Sync | All users marked as 'placeholder' in connector space for domain

Michael 1 Reputation point
2020-12-17T18:33:59.513+00:00

I am replacing an older AAD Connect Sync server with a brand new one. The new server is set up in staging mode using the latest AAD Connect Sync application version while the old server is using 1.2.69.

I exported the configuration from the old server and used it to set up the new (staging) server, so the configuration should be the same. However, after the Full Import from AD, all users are being marked as 'placeholder' in the connector space. I can't seem to get any of the user objects to get pull into the metaverse.

I ran the troubleshooter tool, but there are no apparent reasons for the user(s) to just be 'placeholder's. The proper OUs are all included (same as the old server, which is working without issue).

I have tried re-configuring, reinstalling and playing with the available PowerShell cmdlets but nothing seems to help.

I'm not sure where to go from here with testing, so hoping somebody else has run into this and figured out a solution.

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
19,402 questions
{count} votes

1 answer

Sort by: Most helpful
  1. James Hamil 21,546 Reputation points Microsoft Employee
    2020-12-21T19:51:08.517+00:00

    Hi @Michael , Placeholder means they are referenced as members of a group which is syncing or possibly referenced as managers, but the user objects themselves are not in scope. Are you using any custom rules? If so, check and make sure nothing could be interfering with this. If you're not using custom rules please let me know and we can make a support ticket.

    Best,
    James

    1 person found this answer helpful.
    0 comments No comments