Azure B2C tenant URL all returning AADB2C: An exception has occurred

Antoine HOM 26 Reputation points
2020-12-17T21:00:43.827+00:00

Hello,

We have an issue since tonight on our Azure B2C tenant which always returns "AADB2C: An exception has occurred" on all endpoints and we could not locate any logs that would explain the reason behind this.

Is there a known downtime of the AD B2C service?

Sample return response →
{"CorrelationId":"4f2e7a0e-db39-4476-8fab-a4ccc5d047c6","Timestamp":"2020-12-17 20:56:08Z","Detail":"AADB2C: An exception has occurred."}

Thanks,
Antoine

Microsoft Entra External ID
Microsoft Entra External ID
A modern identity solution for securing access to customer, citizen and partner-facing apps and services. It is the converged platform of Azure AD External Identities B2B and B2C. Replaces Azure Active Directory External Identities.
2,679 questions
{count} vote

Accepted answer
  1. JamesTran-MSFT 36,481 Reputation points Microsoft Employee
    2020-12-18T00:04:18.023+00:00

    @Antoine HOM
    Thank you for your post!

    It looks like there might've been an outage with AzureB2C within West Europe, since we have multiple customers receiving this same error message. Our engineering team is currently looking into this issue and I will update with any RCAs as soon as possible.

    If you require further support with this issue in the meantime, please let me know.
    Thank you for your time and patience throughout this issue!

    ----------

    Please remember to "Accept Answer" if any answer/reply helped, so that others in the community facing similar issues can easily find the solution.

    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. JamesTran-MSFT 36,481 Reputation points Microsoft Employee
    2020-12-22T17:43:13.18+00:00

    @Antoine HOM
    Thank you for your time and patience throughout this issue!

    Root cause:
    The initial root cause for this incident was an operator error during a regular certificate maintenance operation. This certificate is used internally by Azure Active Directory B2C during local sign-in flows.

    The secondary root cause was a gap of synthetic testing to prevent this flawed certificate from being deployed to larger production systems. Initially this certificate was only used in a part of the service that handles a very small slice of pre-production traffic. Per our Safe Deployment rollout automation, we performed automated tests against this part of this service to verify its health. However, there was a gap in our testing system that failed to identify a fault in our service, which allowed the automated rollout system to propagate the flawed certificate to a larger part of the service.

    Mitigation:
    On-call engineers were notified by customer escalation shortly after the service became unhealthy and immediately began mitigation actions, by rerouting traffic from unhealthy to healthy nodes.

    We sincerely apologize for this incident, and its wide scale impact and are committed to address the issues below.


  2. Reshma Mohamed Rafi 0 Reputation points
    2024-05-13T08:14:37.34+00:00

    Im Facing the same issue with Azure AD B2c Custom Policy. When I try to run the Social and local account , the error is showing like this.

    Error:

    AADB2C: An exception has occurred. Correlation ID: 8f8e9cfc-8cad-4162-87af-6b31029c9904

    0 comments No comments