SCONFIG problem / settings not sticking

Jeffrey Tucker 341 Reputation points

hello all, i have an issue. Windows Server 2019 all running as VM in HyperV. i had discovered a couple months ago that some of our servers are doing updates without admin consent. i am old school and like to run them manually in a scheduled downtime window. i went through all the server and ran SCONFIG to change the settings to manual. the resultant screen said custom. but it appears the settings do not stick for some reason. the servers running 2012R2 do not seem to be affected. i am certain we have no GPOs configured to do updates. i also run MECM (nee SCCM) and the servers are not part of updates distribution. any ideas? thanks

Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management updated to data storage.
3,444 questions
0 comments No comments
{count} votes

Accepted answer
  1. Dave Patrick 426K Reputation points MVP

    You can set this one to Disabled
    If the status for this policy is set to Disabled, any updates that are available on Windows Update must be downloaded and installed manually.


    --please don't forget to Accept as answer if the reply is helpful--

    1 person found this answer helpful.
    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. Teemo Tang 11,331 Reputation points

    Disable Configure Automatic Updates policy is a good method.
    Also, you could enable policies in Computer Configuration > Administrative Templates > Windows Components > Windows Update > Windows Update for Business to control feature update.


    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. Jeffrey Tucker 341 Reputation points


    thank you for the ideas. i have to wait a few weeks before i know the result.