After upgrading to net5.0.1 version err in Mysql

Pritam Savagavi 1 Reputation point

From dotnet core 3.1 i have updated to dotnet 5.0.1 now I'm getting error...

" Detected package version outside of dependency constraint: Pomelo.EntityFrameworkCore.MySql 3.2.4 requires Microsoft.EntityFrameworkCore.Relational (>= 3.1.8 && < 5.0.0) but version Microsoft.EntityFrameworkCore.Relational 5.0.1 was resolved."

i have already updated the mysql dependencies...
how to resolve it???

.NET Runtime
.NET Runtime
.NET: Microsoft Technologies based on the .NET software framework.Runtime: An environment required to run apps that aren't compiled to machine language.
1,116 questions
0 comments No comments
{count} votes

4 answers

Sort by: Most helpful
  1. Matheus Botura 6 Reputation points

    It is working here, I had to install Pomelo preview version:

    <PackageReference Include="Pomelo.EntityFrameworkCore.MySql" Version="5.0.0-alpha.2" />

    All other packages are in 5.0.1

    1 person found this answer helpful.
    0 comments No comments

  2. Peter Kellner 1 Reputation point

    There is a lot of chatter about MySql connect not working yet with net5.0.1. You can read issues here with comments up to yesterday still going on.

    I'm doing the same thing right now and going back to 3.1.1 I think.

    0 comments No comments

  3. Pritam Savagavi 1 Reputation point

    Yes, same here now,

    somehow it supports .NET 5.0.0 , I tried to install that version but by default its get 5.0.1 installed,
    So, I'm back with 3.1 core. and waiting for the update for .NET 5.0.1

    0 comments No comments

  4. AlbaneseQuattroLife 1 Reputation point

    You can check your csproj and add/update the package to ---> <PackageReference Include="Pomelo.EntityFrameworkCore.MySql" Version="5.0.0-alpha.1" />

    0 comments No comments