Valid certificate but still get SSL errors

Kyle Blocher 21 Reputation points
2019-12-02T17:06:39.247+00:00

Hello,

We have a cert for our site https://www.blocherconsulting.com
If you browse there, sometimes you get the *.azurewebsites.net built-in certificate, like this:
However, multiple sites that check certificate validity return the correct result: https://www.sslshopper.com/ssl-checker.html#hostname=blocherconsulting.com

We've tried various things like flushing the DNS of the client machine, trying it on domain machines, non-domain machines, etc. But a lot of our clients also report that they see this issue.

Why would Azure serve up the default certificate when the certificate is configured within App Service and verified internally and externally?

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
7,326 questions
0 comments No comments
{count} votes

Accepted answer
  1. Sam Cogan 10,337 Reputation points MVP
    2019-12-02T20:43:12.743+00:00

    The issue is your DNS. You have got 2 A records setup for blocherconsulting.com that are pointing to two different IP addresses.

    alt text

    So traffic is going to two different places, one which has a valid cert, and one does not. You need to remove the incorrect DNS record.

    1 person found this answer helpful.

0 additional answers

Sort by: Most helpful