How do I disable Virtualization based Security in order to use the Ryzen Master software?

Nicholas Steel 336 Reputation points
2020-03-31T09:26:29.037+00:00

When I open Ryzen master I'm presented with this opaque error message:

AMD Ryzen Master

Ryzen Master can only run with Virtualization Based Security (VBS) disabled in the Windows operating system. Please disable VBS and re-start Ryzen Master.

Virtualization-Based Security (VBS)!

OK

I've tried the following to resolve this without success:

1) Disable VBS in the Device Guard Group Policy (GPEdit)
2) bcdedit /set hypervisorlaunchtype off (in an administrative control panel)
3) uninstalling Hyper-V

Update since the original message was posted:

Disable the following Windows components:
Windows Hypervisor Platform
Virtual Machine Platform
Microsoft Defender Application Guard

Turn off this setting:
PC Settings > Windows Update > Windows Security > Device Security > Core Isolation > Memory Integrity (alternatively use the Search Function and search for Core Isolation). Ensure it remains off after a reboot.

Windows 10 Setup
Windows 10 Setup
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
1,915 questions
{count} vote

Accepted answer
  1. Nicholas Steel 336 Reputation points
    2020-03-31T09:49:12.137+00:00

    Solved, I had to disable "SVM" in the UEFI/BIOS. That error message from AMD was extremely misleading!

    Edit: Better solution: https://learn.microsoft.com/answers/comments/149740/view.html

    4 people found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. Marc P 11 Reputation points
    2020-11-03T15:13:52.677+00:00

    I've disabled SVM in the UEFI/BIOS which did not resolve my issue.

    I've also tried disabling VBS in the Device Guard Group Policy (GPEdit) which seems to only be a temporary fix. After a day or so of regular use and a couple reboots the system appears to restore itself and I'm right back to where I started with the same error message:

    Ryzen Master can only run with Virtualization Based Security (VBS) disabled in the Windows operating system. Please disable VBS and re-start Ryzen Master. Virtualization-Based Security (BVS)!

    2 people found this answer helpful.