Unable to play video in script editor or CEWP

Jayashri Thorat 351 Reputation points
2020-12-23T10:05:15.44+00:00

Hi,

I have tried adding embed code for video file using Script Editor web part & also CEWP but in Chrome browser it's asking for "Silverlight Plugin"

Can you please guide on this.
Thanking you in advance.

Regards,
Jayashri

SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
9,561 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. JoyZ 18,041 Reputation points
    2020-12-24T05:59:27.767+00:00

    Hi @Jayashri Thorat ,

    Microsoft Silverlight is no longer supported on Chrome version 45 or a later version of Chrome.

    Try to use the browser supported Microsoft Silverlight or use Embed web part(Which works on modern page) to display mp4 file on your SharePoint page:

    https://support.microsoft.com/en-us/office/add-content-to-your-page-using-the-embed-web-part-721f3b2f-437f-45ef-ac4e-df29dba74de8

    ---------------------------------------Update-------------------------------------------

    From your description, you are using the classic page of SharePoint online, please refer to the simple test with content editor web part for your reference:

    1) I upload the SampleVideo to the SiteAssets library.

    2) Edit the content source like this, remember to change the site name for yourself:
    50890-image.png
    3)Result in chrome browser:
    51073-video.gif


    If an Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Jayashri Thorat 351 Reputation points
    2021-01-08T07:21:19.187+00:00

    Hi, sorry for late reply. I have tried doing the way you have mentioned but it did not work still .
    I am able to add video as mentioned by you, seems like below:
    54755-video1.jpg

    And when I try to click on play button then it appears like below:
    54805-image.png

    Please guide me further