Get error that Search Service Application on server is not provisioned

MDuBose 711 Reputation points
2020-12-23T17:00:40.933+00:00

Hello,

On my SP2016 on premise version, in Central Administration, I've noticed on the Search Administration page, error: "The search application 'Search Service' on server is not provisioned. Confirm that the Microsoft SharePoint Foundation Timer service and Central Administration service are running on the server." I've confirmed that both services are running. Although I'm getting this error, I'm able to search items on my SharePoint site. I've found an article about this error and tried the below steps:

Step 1: Disable the Application Server administration service timer job by using central administration -> Monitoring -> Review job definitions->Application server administration service timer job ->Disable

Step 2: Open the windows service administration (Services.msc) and stop the windows SharePoint timer services

Step 3: Go to %SystemDrive%\ProgramData\Microsoft\SharePoint\Config, here you can find the config file and number of XML files.

Step 4: Delete all xml file's and open the config and change the value as 1

Step 5:Then start the windows SharePoint timer service (services.msc) and wait for few minutes to generate the new xml files and open the config file and confirm the count is greater than 1 eg: 415543

Step 6: Then enable the SharePoint timer services using central administration

The above steps did not fix the error.

I found another article where a user was able to fix the error by running the below Powershell script:

$ssa = Get-SPEnterpriseSearchServiceApplication "Search Service Application"
$ssa.RefreshComponents()

I haven't ran the script above yet because I'm unsure if there's any negative ramification. Can someone shed light on the RefreshComponents method? Also, is there another method different from what I've already tried for resolving the issue?

SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,795 questions
{count} votes

Accepted answer
  1. MDuBose 711 Reputation points
    2021-01-05T19:16:08.09+00:00

    Hi @Elsie Lu_MSFT ,

    These are the steps I've followed.

    1. First, I'd attempted to run an Backup-SPFarm since I was resetting the service account in Central Administration. When I ran Backup-SPFarm, it hung for hours and never completed. After 8 hours of the command hanging, I'd stopped the command. As a result, the Search Application then displayed as Crawler background activity Backup/Restore
    2. Second, I'd attempted to run a Poweshell command to resume the Search Application but that hung as well.
    3. Third, I'd restarted the Windows SharePoint Server Search 16 service. That did not resolve the issue.
    4. Lastly, I'd ran the Powershell scripts below which resolved the issue.
      $ssa = Get-SPEnterpriseSearchServiceApplication "Search Service Application"
      $ssa.RefreshComponents()

    I still don't know the root cause and could not find information that seemed specific to the issue in the Event Viewer or ULS log. However, running the script solved my problem.


1 additional answer

Sort by: Most helpful
  1. Elsie Lu_MSFT 9,756 Reputation points
    2020-12-24T08:59:56.983+00:00

    Hi @MDuBose ,

    Per my understanding, this may be that a component of the search service application on one of your servers is not running normally. And this command you mentioned means to refresh the SSA components on your server. You could try to run this command to test whether it works.

    For better troubleshooting, You could: 1.Check your components status in CA>Search Service Application>Search Administration: 51063-16.jpg

    2.Please check your ULS log and event viewer to see if there are more error messages. This is important, please be sure to do it.

    3.I’m not able to reproduce your issue, however I have found some similar posts for you, you could have a look. https://sharepoint.stackexchange.com/questions/213932/sharepoint-search-service-is-not-provisioned http://www.networksteve.com/forum/topic.php/Event_ID_6482:%C2%A0_Search_not_provisioned:%C2%A0_There_is_no_project_Por/?TopicId=57538&Posts=1

    =============================Update1================================== You could try to: 1.Go to Start > Administrative Tools > Services to restart the SharePoint Search service to test if it works: 52120-2.jpg If the issue is not resolved, stop this service, go to the CA>Security>Configure service account, reset the Search account and go back to restart the service: 52130-3.jpg 52178-4.jpg

    2.Reset the crawl index (clears the index): 52241-5.jpg

    3.Stop and then start the SharePoint Server Search - Central Administration: stop and then restart the service.

    4.Reset default content access account: 52205-6.jpg

    Based on your description, I want to confirm some more information:

    1. How many content sources do you have? Have you checked each one? Try this to get the status: $ssa = Get-SPEnterpriseSearchServiceApplication 'Search Service Application' Get-SPEnterpriseSearchCrawlContentSource -SearchApplication $ssa -Identity 'Local SharePoint Sites'

    2.Based on you can search the items, try to add something new and crawl again to test whether it works now and check the crawl log. 3.Try this to get the state of the components in the default search application:

    Get-SPEnterpriseSearchServiceApplication | Get-SPEnterpriseSearchStatus –Text
    

    The second error message you mentioned is a general error, are there other directional error messages? I have found an article you can have a look. And if the two commands are valid, or if there are any updates on this issue, please share with us.

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


    If the answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.