<<<Resolution Update>>>
Below is the RCA for this issue as updated by the support team:
Issue:
Azure VPN Client (OpenVPN) with AAD fails to connect to Azure with errors: "Access Denied" or "Cannot find file specified".
Cause:
Something changed permissions to HKLM:\SYSTEM\CurrentControlSet\Services\Dnscache and removed access for "NT Service\DnsCache" user group.
This group is used by dnscache service to update DnsClientNrptRule in registry.
Failure to update the registry key leads to the error.
Resolution:
After adding required permissions, VPN Connection was established.
Because issue was observed on several machines, @Alexander Shushanidze wrote a script to fix the problem.
VPN PG has been informed about this issue and they will investigate further and try to fix the issue, if it is caused by VPN Client.
Thanks,
Gita
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Please "Accept the answer" if the information helped you. This will help us and others in the community as well.
Sorry, my fault. I reassigned privileges again and it's working now. I don't know what I messed up for the first time.
@Branislav Košík , thank you for the update, I'm glad to hear that the issue is fixed for you. Please upvote the answer to help others in the community looking for resolution to this issue.
Regards,
Gita