NCSI doesn't like Docker and Pi-Hole

ElastiCourse 26 Reputation points


I'm troubleshooting an issue with Windows PCs running Docker and Local DNS server like Pi-Hole, causing NCSI to always show "No Internet" Status.

Docker + DNS server take about 30 seconds to boot and start operating, I have tuned the parameters within the following regedit path in multiple tries, no luck

Allowed Global DNS via GPO, updated policy, no luck.

For me is more than cosmetic issue because in update 20H2 this causes Windows Store to not be able to download any new apps. Any WSL distro I try to download gives PAR authentication error, I prefer not to login but even if I try to it gives no internet message, same applies to Windows Store troubleshooter, they all report no internet even though Internet works.

Windows 10 Network
Windows 10 Network
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Network: A group of devices that communicate either wirelessly or via a physical connection.
1,997 questions
Windows DHCP
Windows DHCP
Windows: A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.DHCP: Dynamic Host Configuration Protocol (DHCP). A communications protocol that lets network administrators manage centrally and automate the assignment of Internet Protocol (IP) addresses in an organization's network.
938 questions
No comments
1 vote

Accepted answer
  1. Candy Luo 12,476 Reputation points

    Hi ,

    Based on my understanding, now your issue is that NCSI reports no internet. Is that right? Please feel free to let me know if I have any misunderstanding.

    Make sure [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet] EnableActiveProbing set to 1.

    Make sure passive probing be enabled as well. In case active probing fails, passive probing can also detect internet unless it’s disabled by GPO. Check below to make sure you didn’t disable passive probing. If it is, enable it and test again.

    Group Policy path: Computer Configuration\Administrative Templates\Network\Network Connectivity Status Indicator

    Setting: "Specify passive polling" = Enabled, uncheck "Disable passive polling"

    This GPO setting can be also confirmed from this registry key:

    [HKLM\Software\Policies\Microsoft\Windows\NetworkConnectivityStatusIndicator] NoActiveProbe set to 0 (should either not present or value must be 0)

    Restart the machine and see if NCSI still reports no internet.

    In addition, make sure you have patched your OS with fully windows updates.

    Best Regards,



    If the Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

1 additional answer

Sort by: Most helpful
  1. ElastiCourse 26 Reputation points

    NoActiveProbe set to 0 was the magic key to fix it, thanks so much