Unable to provision AppCatalog in SharePoint Online

Mike Sharp 131 Reputation points
2020-12-29T00:25:21.843+00:00

As a tenant admin, I've tried to create an App Catalog site a number of times, but it fails to provision and shows up in the deleted sites list for a brief period (deleted by System Account. I've engaged Microsoft Support, but so far have had zero progress on that front, beyond acknowledging the fact that the App Catalog site does not provision, which I already knew.

Since I don't have access to trace logs, I can't tell what the exception is. I'm hoping someone has a few ideas of missing dependencies or other potential problems that I can investigate. I realize this is a low percentage shot in the dark, but I'm open to suggestions.

One possible issue that may be related is a problem with some site columns and content types I created, and later deleted, once I decided to use a different CT structure. However these CTs and site columns appear in new site collections, even though they don't exist on the Content Type Hub. I don't see how this could impact the creation of an App Catalog, but I thought I'd mention it.

SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
9,989 questions
0 comments No comments
{count} votes

Accepted answer
  1. Mike Sharp 131 Reputation points
    2020-12-29T22:02:30.343+00:00

    Thanks for your reply @AllenLiu-MSFT

    1. Yes, I followed the standard steps to create one. I've tried quite a few times with various URLs for the site.
    2. I did check the time zone previously (its set to Pacific Time).
    3. The PowerShell snippet you provided would not have worked in this case, because there is no site at the AppCatalog URL and Add-SPOSiteCollectionAppCatalog requires a global App Catalog.

    However, the good news is my last attempt yesterday did finally provision an App Catalog site, but it took about 12 hours to complete provisioning! Today when we checked, the site was working.

    Since I don't have access to the trace/uls logs, I don't know what changed or why the previous dozen or so attempts failed. I did try a new URL, on the theory that the previous failures left some sort of orphaned site in the configDB, but I'd tried several different URLs before.

    Anyway, thanks for your response! The problem is fixed now, but I don't know why. :)

    1 person found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. Allen Xu_MSFT 13,791 Reputation points
    2020-12-29T07:46:36.343+00:00

    Hi @Mike Sharp ,

    Per my test, I couldn’t reproduce your issue in my end. This does a strange phenomenon. Let’s verify the followings to narrow down your issue.
    1. Did you create a App Catalog site collection via following the steps in this article: Create the App Catalog site collection? Did you encounter any errors during the creation process? Did you mean that the site collection you created moved to Deleted sites automatically instead of showing up in Active sites?

    2. Go to Settings -> Site creation in SharePoint admin center -> match the time zone with the system's time zone. Someone raised the issue like yours solved it by this way.
    51971-1-1.png

    If the issue still persists, please try to use the below PowerShell scripts to create a App Catalog site collection. Please share here if any error appears when running the script.

    #Define Variables  
    $AdminCenterURL = "https://XXX-admin.sharepoint.com"  
    $AppCatalogURL="https://XXX.sharepoint.com/sites/XXX"  
       
    #Connect to SharePoint Online  
    $Cred = Get-credential  
    Connect-SPOService -url $AdminCenterURL -Credential $Cred  
       
    #Set Site Collection as App Catalog  
    $Site = Get-SPOSite $AppCatalogURL  
       
    #Set Site collection as app catalog  
    Add-SPOSiteCollectionAppCatalog -Site $Site      
    

    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments