question

MartinBilda-7257 avatar image
0 Votes"
MartinBilda-7257 asked MartinBilda-7257 commented

How do bots work properly in App Studio?

Hi,
I have created a sample organization with AAD using the E5 license. This allows me to use teams as well. Now I want to use App Studio to create my own Team App and add a bot. In the App Studio settings you will find the Bots button where you can create a new Bot. I have done this and added a messaging endpoint. This points to a locally hosted web service.
URL: https://www.localhost:8443/services/rest/mywebservice
According to App Studio, you don't need more settings. Now I create my app and upload it to my MSTeams team by clicking the button "Upload Custom App". It is now also available to me. I can access the app via @mention. But if I type "@mention hello" now, nothing happens.
If I access my web service via Postman I get the response: "Hello, I am the response". What am I doing wrong? Please help me!

office-teams-windows-itpro
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

MartinBilda-7257 avatar image
0 Votes"
MartinBilda-7257 answered

I have found a solution for my problem myself. So all those who might have the same problem: Microsoft teams do not support web service endpoints on localhost!
I got ngrok and created a tunnel to my localhost address. So it worked!

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

JimmyYang-MSFT avatar image
0 Votes"
JimmyYang-MSFT answered MartinBilda-7257 commented

Hi MartinBilda!
You can try to check your steps by referring to this official documents:
https://docs.microsoft.com/en-us/microsoftteams/platform/bots/how-to/create-a-bot-for-teams

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thanks for your answer JimmyYang-8258
I did everything just like your link says. But unfortunately there is no solution for my problem.

0 Votes 0 ·