NitzanShahar-3961 avatar image
0 Votes"
NitzanShahar-3961 asked azure-cxp-api edited

connecting to Ubuntu vm on Azure Lab

Dear All,

I would really love your help with an error I am fighting for some time.
I try to connect to an Ubuntu vm in Azure lab, and keep getting an error when the vm tries to connect to 5910 (see screenshot attached).

I did the following steps: I have set up an Azure Lab with Ubuntu 16.04 LTS. I have connected using SSH and installed RDP and GUI on the template. I then published the template and tried to connect to a vm. I downloaded the RDP link, the vm starts and asks for a password (which I provided correctly). It then says in the vm that connection to 3350 is ok but immediately after tries to connect to 5910 and return an error - problem connecting.
I did configure my firewall - and I don't believe this is where the issue is coming from. I also tried to completely shut down my firewall (just in case config is wrong) and it didn't help.

I would very much appreciate your help.




untitled.png (5.8 KiB)
· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

can you post the logs of xrdp

0 Votes 0 ·

@NitzanShahar-3961 Is there any update?

0 Votes 0 ·


An address that sends outgoing signals back to the same computer for testing. In a TCP/IP network, the loopback IP address is, and pinging this address will always return a reply unless the firewall prevents it. The loopback address allows a network administrator to treat the local machine as if it were a remote machine. Did you also check the firewalls on your local machine? Are you using a VPN? Like we said below if you confirm that first and then check your logs you should be up and running!

0 Votes 0 ·

0 Answers