Hello @Mitchell Meadows ,
Issue description:
When attempting to connect to the P2S VPN using the Windows store client and AAD you receive the following error:
Vpn connection noname could not be saved. Platform error code: 5
Cause:
This is currently being caused when FIPS aka Federal Information Processing Standards is enabled via a group policy or similar. Disabling FIPS mitigates but some customers have a hard requirement to have this enabled.
How to check if FIPS is enabled:
- Press Windows Key+R to open the Run dialog.
- Type “gpedit.msc” into the Run dialog box (without the quotes) and press Enter.
- Navigate to “Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options” in the Group Policy Editor.
- Locate the “System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing” setting in the right pane and double-click it.
- See if enabled or disabled.
Solution:
Disable FIPS (if possible).
Or manually install the following KB:
https://www.catalog.update.microsoft.com/Search.aspx?q=KB4577063
Post that reboot your machine and try to connect to PS VPN again and check if it connects successfully.
Kindly let us know if the above helps or you need further assistance on this issue.
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