Azure VPN P2S Platform 5 error

Mitchell Meadows 21 Reputation points
2021-01-11T18:16:27.737+00:00

We have recently setup a Generation1 VPN Gateway using our AD Authentication. I have created an xml file for import, roughly 25 users for their P2S configuration. Utilizing the Azure VPN connection Client from the Windows store we are allowing them to install and import the file since we are 100% remote. I have a few users that are getting an error: "VPN Connection NoName could not be saved. Platform Error Code: 5" The xml is titled in case someone asks.

The error code is random, the same exact model machines with the latest updates (1/7/21) are not having the issue. We have attempted to manual enter the information, same error. We have created a totally new xml file from Azure, same error. Searching the web and this forum I have found no instance of this being reported.

I have attached a copy of the error from my user's error.55467-inkedplatform-error-5-li.jpg

Azure VPN Gateway
Azure VPN Gateway
An Azure service that enables the connection of on-premises networks to Azure through site-to-site virtual private networks.
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Accepted answer
  1. GitaraniSharma-MSFT 50,096 Reputation points Microsoft Employee Moderator
    2021-01-12T07:17:55.07+00:00

    Hello @Mitchell Meadows ,

    Issue description:
    When attempting to connect to the P2S VPN using the Windows store client and AAD you receive the following error:
    Vpn connection noname could not be saved. Platform error code: 5

    Cause:
    This is currently being caused when FIPS aka Federal Information Processing Standards is enabled via a group policy or similar. Disabling FIPS mitigates but some customers have a hard requirement to have this enabled.

    How to check if FIPS is enabled:

    • Press Windows Key+R to open the Run dialog.
    • Type “gpedit.msc” into the Run dialog box (without the quotes) and press Enter.
    • Navigate to “Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options” in the Group Policy Editor.
    • Locate the “System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing” setting in the right pane and double-click it.
    • See if enabled or disabled.

    Solution:
    Disable FIPS (if possible).
    Or manually install the following KB:
    https://www.catalog.update.microsoft.com/Search.aspx?q=KB4577063

    Post that reboot your machine and try to connect to PS VPN again and check if it connects successfully.

    Kindly let us know if the above helps or you need further assistance on this issue.

    ----------------------------------------------------------------------------------------------------------------

    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.


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