'Element not Found' when using EFS on Windows 2008

shockoQA-1 61 Reputation points
2021-01-14T13:41:50.71+00:00

Our PKI is Windows 2016 with ADDS forest/domain functional level at 2008 R2. When attempting to encrypt a file on a Domain joined Windows 2008 (not R2!) machine we received the following:

  • 'Element not found'

Our recovery agent is in place and we have no issues on Windows 2008R2 or above. From troubleshooting this only occurs is KSP is used as the cryptographic provider in the PKI template. If we use the legacy provider in the template the file encrypts without issues.

Windows Server Security
Windows Server Security
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.Security: The precautions taken to guard against crime, attack, sabotage, espionage, or another threat.
1,746 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Hannah Xiong 6,236 Reputation points
    2021-01-15T01:43:46.187+00:00

    Hello,

    Thank you so much for posting here.

    We could kindly have a check whether the below link helps.
    https://social.technet.microsoft.com/Forums/Lync/en-US/3fe04ba4-2248-4b6c-9a9a-8b9b6b4ca64a/element-not-found-when-duplicating-basic-efs-template?forum=winserversecurity

    Best regards,
    Hannah Xiong

    ============================================

    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.