Not able to connect to VM through RDP

NN_VM 1 Reputation point
2021-01-15T15:59:43.29+00:00

We are not able to connect to VM using RDP. We added 3389 port at inbound, restarted, redeployed. But still did not work.

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,246 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Sumarigo-MSFT 43,911 Reputation points Microsoft Employee
    2021-01-15T16:20:54.69+00:00

    @NN_VM Welcome to Microsoft Q&A, Thanks for raising your query.

    Are you getting any error message or error code? If, so can you share the screenshot of the error?

    The Remote Desktop Protocol (RDP) connection to your Windows-based Azure virtual machine (VM) can fail for various reasons, leaving you unable to access your VM. The issue can be with the Remote Desktop service on the VM, the network connection, or the Remote Desktop client on your host computer. This article guides you through some of the most common methods to resolve RDP connection issues.

    Troubleshoot Remote Desktop connections to an Azure virtual machine

    This article provides detailed troubleshooting steps to diagnose and fix complex Remote Desktop errors for Windows-based Azure virtual machines. See here

    RDP port 3389 is exposed to the Internet. Therefore, we recommend that you use this port only for recommended for testing. For production environments, we recommend that you use a VPN or private connection.

    Also, please refer to this article explains how to resolve a problem in which you cannot connect to an Azure Windows virtual machine (VM) because the Remote Desktop Protocol (RDP) port is not enabled in the network security group (NSG).

    Troubleshoot an RDP general error in Azure VM: This article describes a general error you may experience when you make a Remote Desktop Protocol (RDP) connection to a Windows Virtual Machine (VM) in Azure.

    If the issue still persist, create a new rule by clicking the "Add Inbound Port Rule" and allow traffic from port 3389. Make sure that the priority of this new rule is greater than the "DenyAllInBound" rule otherwise our new rule will not have any effect.

    After adding the rule, try connecting to the VM using its public IP in RDP and you should be able to connect.

    If the issue still persist, please provide the below mentioned details for further troubleshooting:

    • Which version of OS(VM) are you using?
    • Is this a gallery or custom image?
    • Is this a generalized or specialized image?

    Hope this helps!

    Kindly let us know if the above helps or you need further assistance on this issue.

    -----------------------------------------------------------------------------------------------------------------------------

    Please don’t forget to "Accept the answer” and “up-vote” wherever the information provided helps you, this can be beneficial to other community members.