Problem sending replies mails to Office 365

Abdelhalim Zerroug 21 Reputation points
2021-01-16T17:12:01.023+00:00

Hi

We have Exchange server 2013 with Edge server 2010 (I know, this is not conventional), for some time now, sending emails to our partners with an Office 365 messaging system has not been received, the strangest thing that if the message is new (new message), it arrives at destination, but if it is a reply or thread, the message does not arrive, knowing that our domain and Ip mx are not blacklisted. Apart from a partner who added our domain to their list of trusted domains, the problem persists for others.

thanks

regards

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,388 questions
{count} votes

Accepted answer
  1. Eric Yin-MSFT 4,386 Reputation points
    2021-01-19T08:54:32.417+00:00

2 additional answers

Sort by: Most helpful
  1. Eric Yin-MSFT 4,386 Reputation points
    2021-01-18T08:15:21.26+00:00

    So you have confirmed the issue occur with several O365 domains, and you cannot reply messages from all of them except one who added you to trusted domains?
    Check the message header from them, does it contain "Reply-to" which is different from "From"?
    Please track the "reply" message from O365 side, compare the results with "send" message and see what's the difference: https://www.codetwo.com/admins-blog/message-tracking-office-365/
    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. Abdelhalim Zerroug 21 Reputation points
    2021-01-19T07:16:23.253+00:00

    I confirm that the issue occur with several O365 domains, and in most cases, I can not send message to them (some time the message is received), except who added us to trusted domains. Miscrosoft Support said that all is ok in our side.
    We were able to track the message on the other side, the rejected messages are quarantined or classified as spam, Why? our domain and our IP of our MX are not Blacklisted.

    0 comments No comments